Jetson Xavier NX L4T 35.1.0 Long Boot Time

Hello!

My Xavier NX is taking a long time to boot. 5-8 minutes on average.
It happens every time. With HDMI connected, I can see the following screen. Pressing ESCAPE does nothing.

Each line takes just about a minute to time out.

>>Start HTTP Boot over IPv6.
Error: Could not retrieve NBP file size from HTTP server.

Error: Unexpected network error.

>>Start HTTP Boot over IPv4.
Error: Could not retrieve NBP file size from HTTP server.

Error: Server response timeout.

>>Start PXE over IPv6.
PXE-E16: NO valid offer received.

>>Start PXE over IPv4.
PXE-E18: Server response timeout.

Then the rest pops up pretty quickly and it boots up successfully.

Is there any way to disable HTTP Boot over IPv6/4 and Start PXE over IPv6/4?

uname -a
Linux AeroDB601C 5.10.104-tegra #1 SMP PREEMPT Wed Aug 10 20:17:07 PDT 2022 aarch64 aarch64 aarch64 GNU/Linux

I have replicated the issue across two Jetson Xavier NX boards, both flashed to NVMe. My software requires more space than available on eMMC.

Any help would be greatly appreciated.

Kind regards,
Sam

1 Like

Suggest to do a full reflash with the JetPack 5.0.2 GA release to see if issue still presented.

Hi kayccc,

I have completed a full reflash with JetPack 5.0.2 GA and the issue is still presented every time I boot it up.

Can’t press ESCAPE to get into the boot options (tried 2 different keyboards, different USB cables, different USB ports etc).

Please let me know what I should try next.

Thanks!

Hi,

Please dump the serial console log from uart.

Also, since UEFI default does not print any log, you need to rebuild the UEFI source code here and there would be a debug binary which enable log print.

Replace that debug binary with original UEFI binary in L4T and reflash the board. Dump the full log again.

Are you using devkit or custom board?

Hi WayneWWW, if you look closely at the messages displayed, it shows that its not finding the boot disk and goes looking for every other option first. When pressing escape at exactly the right moment it presents a boot menu. When the correct boot disk is selected it boots normally. But it does not remember this selection so we have the same issue on every boot.

What we need to know is how to make it remember that the boot disk is the M.2 SSD NVMe disk so that each time it boots it looks for this boot option first. The issue is analogous to the PC BIOS settings where you set the boot drive in BIOS.

BTW, we used the Nvidia SDK version 1.8.1.xxxxx and it has no problem with imaging the NVMe disk so its not like we are doing anything outside the standard operating system options provided by the SDK.

The Module is a NX, 16G, SOM. This problem does not occur if we image the flash on the SOM.

Can you provide instructions on how to force the boot option to be NVMe SSD on every boot cycle.

Hey @rapidproto

I have reported a bug here:

@WayneWWW this was right before my vacation, the bug report was automagically selected as solution, while the topic is not solved yet.

The initrd flash tool does not seem to update the UEFI to boot from NVME, you need to change it manually.
Connect to the board via serial, enter uefi, change the boot order and save with F10. Then instead of pressing “continue” in the mail menu select “reset”. Then the option should be changed. I noticed that when you press continue, it will forget the option despite you having it saved before.

This has to be done every time after flashing the board.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.