Jetson Xavier NX module imx219_board_setup error

Hello there,

I am using a custom carrier board for the Jetson Xavier NX module ( I am trying to connect two Waveshare IMX219-200 cameras to the board ( but while booting the device there is the following error: imx219_board_setup error (see image below)

I tried several things:

  1. Switching to another EN715 carrier board (just in case the board was broken)
  2. Flashing the Module via SDKManager (Jetpack 4.4.1)
  3. Flashing the Module via SDKManager (Jetpack 4.4.1) and updating kernel via BSP (version R1. (Beta) for Jetson Xavier NX) command: sudo ./ -k kernel-dtb jetson-xavier-nx-en715 mmcblk0p1
  4. Flashing the module using BSP
  5. Also I tried to swap the module. The cameras are working using the Jetson Xavier NX devkit and its integrated module. We tried to use the carrier board EN715 with the development module but that does not work either

Now I am asking if you have any suggestions to solve this problem. I need to get a video stream out of both cameras simultaneously using a gstreamer pipeline (gst-launch-1.0)

Thanks in advance!

You may need to check the HW of carrier board for the sensor power/reset pins with devkit.
It’s could be something different cause the sensor board not working on carrier board.

One thing I forgot to mention: the error even appears if no camera is connectet to the board while booting

Yes, if there’s no HW connection it’s failed to probe the by the sensor driver.

I found something for the CSI connectors of the board but i don’t know if they are wrong

@ShaneCCC could you support on this one? I don’t know how to continue from this point

I would suggest consult to vendor to check if need any driver modification or any HW connection need to note.