MIPI CSI issue (Imx219_board_setup: error during i2c read probe (-121))

Dear Nvidia Community,

I just bought an Nvidia jetson xavier nx platform.
The SD card image was downloaded from:

The sd card was flashed and system up running. But there is an imx219_board_setup error.
I can not use the MIPI CSI ports.
I have a Raspberry pi hq camera and even that does not work.
You can see the image below when I boot my platform.

It’s could be the HW connection problem cause the i2c failed.

Thank you ShaneCC for your message.
The external camera I want to connect has specific drivers.
I changed the camera cable and several times I connect and disconnect that but nothing.So, without installing the camera drivers it appears me the above message.
Also if i type v4l2-ctl–list devices it appears me:

Do I have to install something from the start. I am asking because I am new with that platform

Need to install the v4l-utils by sudo apt-get install v4l-utils

1 Like

I did that and still the same message appears.

Need space after the v4l2-ctl like below.

v4l2-ctl --list-formats

ok now it appears me:

dask@dask-desktop:~$ v4l2-ctl --list-formats
ioctl: VIDIOC_ENUM_FMT
Index : 0
Type : Video Capture
Pixel Format: ‘RG10’
Name : 10-bit Bayer RGRG/GBGB

About the camera I use the Rasberry Pi HQ camera with IMX447 sensor. I had a contact with camera supplier and provided me the drivers:

but the same error appears me when I boot the platform. General is there a solution on that problem or it has to to only with HW?

Thanks for the consideration,