Jetson Xavier NX SD Card Image download problem

Could not download the image successfully either via wget or normal browser. I tried 3 times with my PC and once via mobile phone. At some point it gets frozen.

Hi yusufbaylav,

I can download it by Chrome browser without problem just now, would you please try it again or see if can download other doc/file from https://developer.nvidia.com/embedded/downloads to confirm if that’s local network issue?

There’s not any problem related to starting a download, the problem is it fails after some time in the middle.

And additionally, a few Mbs vs. a few Gbs … I do not believe that will ease the way that I download the image. Why don’t you provide these images in the format of a normal linux distribution image which we can download directly either via torrent or via wget/curl. If it fails at some point it does not even continue from where it has left.

Again I had the same problem. It seems like the download process completed but it was declared that the file is ~6Gb.

I am not sure whether this is the whole file or corrupted on the way. This is really annoying.

As I guessed, file is corrupted. Although it seems completed trying to burn the file to the micro sd resulted with an error. Please provide me an healthy link to download the image. I could not start to play with the device and it costed me more than 10GB of my mobile internet. And I got nothing healthy in my hand. It cannot be a network issue as I tried both with home internet and mobile many times.

It has been days, no solution provided. I found a better connection speed and downloaded it. But it should definitely be more than 40Mbit/sec. Please provide these images with a better system. Starting to play/touch the system should not take multiple days long and should not cost this much!