Kernel mode not recompiling on updates


On linux mint and ubuntu when i installed the nvidia drivers i was given the option to install it so that the kernel module would be recompiled with kernel updates, this is not the case on Fedora. when i run the installer on fedora it just says compiling kernel module, asks if i want 32 bit libraries, installs and is done. Which is rather annoying as any kernel patch or update will render the system unbootable until the drivers are reinstalled. Is there anyway to make it do the same as it did in ubuntu/linux mint?


What I do is run the installer with --extract-only (or similar, check the command line options). This generates the build tree without compiling. Then you can apply your patches, and compile/install running the installer from within that directory.

Not a Fedora expert, but as far as I know the RPMFusion repo ships the driver packages as dkms-like modules that are rebuilt every time.

I don’t see why you’d ever want to install the driver manually unless you’re using a very niche distro that doesn’t have a lot of prebuilt packages.

Reason why i download the drivers is because the RPMFusion repos does not have the latest drivers for fedora 22 as far i could find.