libnvinfer has unmet dependencies

Hello, I have installed Jetpack 3.1 and I’m trying to install TensorRT 3.0 on Jetson TX2. I am following official installation guide, after running sudo apt-get install python3-libnvinfer-doc I get following error:

The following packages have unmet dependencies:
python3-libnvinfer-doc : Depends: python3-libnvinfer-dev (>= 4.0.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Any ideas?

Hi,

TensorRT Python API is only available on the x86-based Linux system, not for Jetson platform.

If you are a TensorFlow user, the recommended flow to run TensorFlow model on Jetson is:
1. Export TensorFlow model to UFF on an x86-machine with python interface:
Sample: /usr/local/lib/python2.7/dist-packages/tensorrt/examples/tf_to_trt/tf_to_trt.py

2. Launch TensorRT engine with UFF format on Jetson with C++ interface:
Sample: /usr/src/tensorrt/samples/sampleUffMNIST/sampleUffMNIST.cpp

Thanks.

Hey i got the same error message but on my x86-based host machine.

The thing is that since i flasohed jetpack3.2 on the jetson from this host it appears that it has some arm64 packages installed on it. This also leads to errors when i run apt-get update.

Did this happen before? If yes how can i get rid of those arm64 (thats jetson’s architecture right?) packages?

Hi,

The TensorRT x86-package is not in the JetPack.
Please download and install via this page:
https://developer.nvidia.com/nvidia-tensorrt-download

And here is the installation guide for your reference.
Thanks.

Hey i got the same error message but on my x86-based host machine. I didn’t use JetPack, I download the TensorRT 5 from
https://developer.nvidia.com/nvidia-tensorrt-download, the file is “TensorRT 5.0.0.10 RC for Ubuntu 1604 and CUDA 9.0 DEB local repo packages”

I followed the step from ‘https://docs.nvidia.com/deeplearning/sdk/tensorrt-install-guide/index.html’.

Every time I try ‘$ sudo apt-get install python3-libnvinfer-dev’, the system tells me:

[b]Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
python3-libnvinfer-dev : Depends: python3-libnvinfer (= 5.0.0-1+cuda9.0) but it is not going to be installed
Depends: libnvinfer-dev (= 5.0.0-1+cuda9.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.[/b]

and then I try ‘dpkg -l | grep TensorRt’,nothing happens!

Hi,

Your TensorRT package is broken(maybe bad network condition?):

E: Unable to correct problems, you have held broken packages.

Could you re-download the package and follow these command to install it again?
https://docs.nvidia.com/deeplearning/sdk/tensorrt-install-guide/index.html#installing-debian

Thanks.