Linux tearing 940MX

I decided to switch to Mate completely, changed the distribution on my laptop. Faced with a long-standing problem - tearing.

Solus Linux 4.3
Kernel: 6.2.14-232
NVIDIA GeForce 940MX
NVIDIA Driver Version: 530.41.03

In the past, I solved this problem by including the option in the kernel boot:

echo "nvidia-drm.modeset=1" | sudo tee /etc/kernel/cmdline.d/50-nvidia-drm.conf
sudo clr-boot-manager update

But now, as I understand it, it doesn’t work.

tee: /etc/kernel/cmdline.d/50-nvidia-drm.conf: No such file or directory

I also tried inserting the boot into GRUB, but that doesn’t work either /etc/default/grub:

 grub-mkconfig -o /boot/grub/grub.cfg

Although lsmod says that everything works:

alexander@notebook ~ $ lsmod | grep nvidia
nvidia_uvm           1617920  0
nvidia_drm             90112  4
nvidia_modeset       1290240  3 nvidia_drm
nvidia              55844864  228 nvidia_uvm,nvidia_modeset
drm_kms_helper        249856  3 drm_display_helper,nvidia_drm,i915
drm                   782336  12 drm_kms_helper,drm_display_helper,nvidia,drm_buddy,nvidia_drm,i915,ttm
video                  65536  3 ideapad_laptop,i915,nvidia_modeset

But checking the parameter says the opposite:

alexander@notebook ~ $ sudo cat /sys/module/nvidia_drm/parameters/modeset

Configuration parameters are also missing in the driver settings:

Maybe something has changed with the advent of a new kernel and new drivers? Is there a solution to eliminate tearing in the new configuration?

I’m not familiar with Solus so I’m not sure how the command line arguments are configured. I would personally recommend using a modprobe configuration file instead, though:

echo "options nvidia-drm modeset=1" | sudo tee -a /etc/modprobe.d/nvidia.conf

Can you please give that a try and if it doesn’t work, run sudo and attach the resulting log file here?

1 Like

Yes, the problem was specifically with the Solus distribution. The issue is resolved:

sudo mkdir -p /etc/kernel/cmdline.d
echo "nvidia-drm.modeset=1" | sudo tee /etc/kernel/cmdline.d/50-nvidia-drm.conf
sudo clr-boot-manager update

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.