Little old but working

Hello i have a desktop with a geforce 200 series with Mint 21 but when i run the file NVIDIA-Linux-x86_64-340.108.run as root it says to leave X and i don’t know how to proceed from here.
I already try to run in on console (alt-F#). Can you help me out?

Installing with .run files is possible but recommended method of driver installation for new users on the likes of Linux Mint is to just let graphical package manager handle it for you. But last driver supporting Geforce 200 series is 340.108, which is unsupported on Linux Mint 21 (supported on 20), so you might actually need that run file. Or use Debian 10. Or Mint 20. Or Ubuntu 20.04.

To turn off GUI on boot, open terminal and run
sudo systemctl set-default multi-user
reboot

On boot, login to TTY and run the run file
cd Downloads
sudo bash ./some-nvidia-runfile.run

If the installer succeeds (or doesn’t), set GUI session back as default with
sudo systemctl set-default graphical
reboot