Login for downloads?

On the main linux for tegra page, it seems all recent downloads require logins, making it impossible to wget any files. This breaks my CI, since my image building scripts can’t obtain the necessary files.

JP Release 4.3 works.

 $ wget --https-only -nv --show-progress --progress=bar:force:noscroll https://developer.nvidia.com/embedded/L4T/r32_Release_v4.3/Sources/T210/public_sources.tbz2
public_sources.tbz2         100%[===========================================>] 142.89M   108MB/s    in 1.3s    
2021-01-19 12:52:59 URL:https://developer.download.nvidia.com/embedded/L4T/r32_Release_v4.3/sources/T210/public_sources.tbz2?OZ6FKnVDn9X7EcdhjiLI3PyVKYngAL98_pSypPE_-7CQ284CJnKdM_uhDoFpRJhNUeGf6m1V66fM6HMUF46q-7qKx_4YXLmNsKFjG37PD5Muw3dS3nytQClT6XQGdeUglPFYq_RY-Km4YaO2iUcdgkpJ9LVDCTMZkdyUEyI [149830549/149830549] -> "public_sources.tbz2" [1]

4.4 requires a login

wget --https-only -nv --show-progress --progress=bar:force:noscroll https://developer.nvidia.com/embedded/L4T/r32_Release_v4.4/r32_Release_v4.4-GMC3/Sources/T210/public_sources.tbz2
2021-01-19 12:45:23 ERROR 403: Forbidden.

I would greatly appreciate it if the login requirement were removed. I appreciate that you’re locking your site down so miners (/me spits) don’t grab all the cards, but the downloads section is useful to be open.


1 Like

Thanks @mdegans for bringing this up - we will take a look into it.

Thanks, @dusty_nv

I’d mirror the files myself, and probably will in the mean time, but I worry about doing that long term considering others use my scripts and my shared hosting is probably not as secure as your dedicated download servers.

Hi @mdegans - this appears to have been fixed now. I tried downloading the 32.4.4 files again incognito, and it didn’t ask for a login. Can you try again and let us know if it still requires you to login?

Thanks, @dusty_nv !

I can confirm it works in incognito and with wget.

It does not work. I cannot install anything.

Hmm I just checked the L4T files again and was able to download them without logging in. Are you able to download this file?


Just to add statistics, I am able to download from that URL.

Same. Just tried it with no issues. Thanks for fixing it.