Login loop when installing CUDA drivers in Ubuntu 16.04 with GeForce RTX 2060 laptop

I have had this problem for a long time. Usually when I get the login loop I go to tty, stop lightdm and reinstall nvidia Cuda drivers with .run file, reboot and it’s solved, but this time is not working.
I need to install Cuda 10.0 or 10.2 for some special’s gear SDK to be compatible.
Attached is the nvidia-bug-report file.

Help is much appreciated. Thanks in advance.
nvidia-bug-report.log.gz (1.1 MB)

Hi community, I can’t solve this problem yet. Any help pls? TIA

Hello, I can’t find a solution in the forum or online. I have tried multiple CUDA version following the official documentation steps but still getting nowhere.

Is this community actually working? Thanks.

Moving this thread from the Linux to the CUDA Setup and Installation forum for better visibility.

Finally I got some release to work on my laptop. Still I don’t know what was causing the problems with the other versions. Version 10.0 worked.
Was essential to do the pre and the post-install actions as stated in the official Documentation.
This is what I did that worked:

echo "blacklist nouveau" | sudo tee -a /etc/modprobe.d/blacklist-nouveau.conf > /dev/null
echo "options nouveau modeset=0" | sudo tee -a /etc/modprobe.d/blacklist-nouveau.conf > /dev/null
sudo update-initramfs -u

sudo service lightdm stop
sudo ~/.../cuda_10.0.130_410.48_linux.run --silent --driver --toolkit --no-opengl-libs

export PATH=/usr/local/cuda-10.0/bin${PATH:+:${PATH}}
export LD_LIBRARY_PATH=/usr/local/cuda-10.0/lib64\
                         ${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}

Thanks for nothing.

Correction, this was the way it finally worked:

    echo "blacklist nouveau" | sudo tee -a /etc/modprobe.d/blacklist-nouveau.conf > /dev/null
    echo "options nouveau modeset=0" | sudo tee -a /etc/modprobe.d/blacklist-nouveau.conf > /dev/null
    sudo update-initramfs -u

    sudo service lightdm stop
    sudo ~/.../cuda_10.0.130_410.48_linux.run

    export PATH=/usr/local/cuda-10.0/bin${PATH:+:${PATH}}
    export LD_LIBRARY_PATH=/usr/local/cuda-10.0/lib64\
                             ${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
 

And have to accept to let the installer handle the X server configuration.