Login screen freezes when HDMI is connected on GTX1060 Mobile

Hi,
I’m using a Predator G3-572 with a GTX1060 Mobile mobile, Ubuntu 20.04.3 kernel 5.11.0-38-generic, nvidia driver 470.74.
When I try to boot my laptop with the HDMI connected, it freezes when the login screen shows up. I already tried removing “quiet splash” from grup config and it didn’t work.

nvidia-bug-report.log.gz (372.7 KB)

Do you have the 5.4. (GA) kernel available in grub menu to test if it works with that?

No, I don’t. There is any way to install it?

You will need 4 packages
linux-headers-XX
linux-headers-XX-generic
linux-image-unsigned-XX-generic
linux-modules-XX-generic
from Index of /~kernel-ppa/mainline/v5.4.158

Did it and updated grub. Got some boot errors. Should I Post the image here? I’m asking because it shows some certificates and I don’t know if they can be shown

These crashes are in your dmesg in you initial bug-report (likely causing the freeze):

[ 24.224155] ------------[ cut here ]------------
[ 24.224159] WARNING: CPU: 1 PID: 7124 at /var/lib/dkms/nvidia/470.74/build/nvidia-drm/nvidia-drm-drv.c:574 nv_drm_master_set+0x27/0x30 [nvidia_drm]
[ 24.224170] Modules linked in: rfcomm ccm nvidia_uvm(POE) snd_hda_codec_realtek snd_hda_codec_generic ledtrig_audio nvidia_drm(POE) nvidia_modeset(POE) snd_hda_codec_hdmi cmac algif_hash algif_skcipher af_alg bnep intel_rapl_msr uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_v4l2 videobuf2_common videodev mei_hdcp nls_iso8859_1 joydev intel_rapl_common x86_pkg_temp_thermal intel_powerclamp coretemp kvm_intel kvm crct10dif_pclmul ghash_clmulni_intel aesni_intel crypto_simd cryptd glue_helper nvidia(POE) rapl snd_hda_intel snd_intel_dspcfg soundwire_intel soundwire_generic_allocation soundwire_cadence snd_hda_codec snd_hda_core snd_usb_audio soundwire_bus snd_soc_core snd_usbmidi_lib snd_hwdep snd_compress mc ac97_bus snd_pcm_dmaengine snd_pcm iwlmvm snd_seq_midi snd_seq_midi_event mac80211 snd_rawmidi btusb btrtl btbcm btintel libarc4 snd_seq bluetooth snd_seq_device input_leds snd_timer ecdh_generic ecc usbhid serio_raw intel_cstate i915 intel_wmi_thunderbolt efi_pstore snd
[ 24.224234] iwlwifi acer_wmi ee1004 sparse_keymap wmi_bmof hid_multitouch soundcore drm_kms_helper cfg80211 intel_pch_thermal mei_me cec rc_core i2c_algo_bit fb_sys_fops syscopyarea sysfillrect mei sysimgblt mac_hid acpi_pad acer_wireless sch_fq_codel msr parport_pc ppdev lp parport drm ip_tables x_tables autofs4 hid_generic rtsx_pci_sdmmc nvme nvme_core ahci r8169 intel_lpss_pci rtsx_pci crc32_pclmul i2c_i801 intel_lpss i2c_smbus realtek idma64 xhci_pci libahci i2c_hid virt_dma xhci_pci_renesas hid wmi video pinctrl_sunrisepoint
[ 24.224275] CPU: 1 PID: 7124 Comm: gpu-manager Tainted: P OE 5.11.0-38-generic #42~20.04.1-Ubuntu
[ 24.224278] Hardware name: Acer Predator G3-572/Sienta_KLS, BIOS V1.22 03/15/2019
[ 24.224280] RIP: 0010:nv_drm_master_set+0x27/0x30 [nvidia_drm]
[ 24.224286] Code: 0f 1f 00 0f 1f 44 00 00 55 48 8b 47 48 48 8b 78 20 48 8b 05 ab 6c 00 00 48 89 e5 48 8b 40 28 e8 3f d0 00 db 84 c0 74 02 5d c3 <0f> 0b 5d c3 0f 1f 44 00 00 0f 1f 44 00 00 55 48 89 e5 41 57 41 56
[ 24.224288] RSP: 0018:ffffb64a4350fb18 EFLAGS: 00010246
[ 24.224291] RAX: 0000000000000000 RBX: ffff8a18517fe800 RCX: 0000000000000008
[ 24.224292] RDX: ffffffffc383ee98 RSI: 0000000000000282 RDI: ffffffffc383ee60
[ 24.224294] RBP: ffffb64a4350fb18 R08: 0000000000000008 R09: ffffb64a4350fb00
[ 24.224295] R10: 0000000000000000 R11: ffffffffc02b01d8 R12: ffff8a185357c000
[ 24.224296] R13: ffff8a18cacfe3c0 R14: 0000000000000001 R15: ffff8a185357c000
[ 24.224298] FS: 00007fb0c3792b80(0000) GS:ffff8a1baec40000(0000) knlGS:0000000000000000
[ 24.224300] CS: 0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[ 24.224302] CR2: 000055a7f4996018 CR3: 0000000110e9e001 CR4: 00000000003706e0
[ 24.224304] Call Trace:
[ 24.224307] drm_set_master+0x55/0x80 [drm]
[ 24.224337] drm_new_set_master+0x4d/0xa0 [drm]
[ 24.224359] drm_master_open+0x6e/0xa0 [drm]
[ 24.224380] drm_open+0x18a/0x260 [drm]
[ 24.224402] drm_stub_open+0xae/0x110 [drm]
[ 24.224426] chrdev_open+0xd3/0x1c0
[ 24.224430] ? cdev_default_release+0x20/0x20
[ 24.224433] do_dentry_open+0x156/0x370
[ 24.224435] vfs_open+0x2d/0x30
[ 24.224438] path_openat+0xb17/0x1120
[ 24.224441] do_filp_open+0x91/0x100
[ 24.224443] ? __check_object_size+0x13f/0x150
[ 24.224446] do_sys_openat2+0x221/0x2e0
[ 24.224449] do_sys_open+0x46/0x80
[ 24.224451] __x64_sys_openat+0x20/0x30
[ 24.224453] do_syscall_64+0x38/0x90
[ 24.224463] entry_SYSCALL_64_after_hwframe+0x44/0xa9
[ 24.224467] RIP: 0033:0x7fb0c3c35eab
[ 24.224469] Code: 25 00 00 41 00 3d 00 00 41 00 74 4b 64 8b 04 25 18 00 00 00 85 c0 75 67 44 89 e2 48 89 ee bf 9c ff ff ff b8 01 01 00 00 0f 05 <48> 3d 00 f0 ff ff 0f 87 91 00 00 00 48 8b 4c 24 28 64 48 33 0c 25
[ 24.224472] RSP: 002b:00007ffc0ca20910 EFLAGS: 00000246 ORIG_RAX: 0000000000000101
[ 24.224474] RAX: ffffffffffffffda RBX: 0000000000000001 RCX: 00007fb0c3c35eab
[ 24.224476] RDX: 0000000000000002 RSI: 00007ffc0ca209e0 RDI: 00000000ffffff9c
[ 24.224478] RBP: 00007ffc0ca209e0 R08: 00000000ffffffff R09: 00007ffc0ca20820
[ 24.224479] R10: 0000000000000000 R11: 0000000000000246 R12: 0000000000000002
[ 24.224480] R13: 00007ffc0ca21ca0 R14: 0000000000000000 R15: 0000000000000000
[ 24.224483] —[ end trace 026521d194136085 ]—
[ 24.225031] ------------[ cut here ]------------

As it looks like gpumanager is involved, could you try booting the 5.11 kernel with the parameter nogpumanager?

https://itectec.com/ubuntu/ubuntu-how-to-add-a-kernel-boot-parameter/

As it looks like gpumanager is involved, could you try booting the 5.11 kernel with the parameter nogpumanager?

I did as said in https://itectec.com/ubuntu/ubuntu-how-to-add-a-kernel-boot-parameter/ and added nogpumanager in the end of GRUB_CMDLINE_LINUX_DEFAULT. It freezing.

Looking at the logs again, it seems there was a wayland session started with the nvidia driver crashing in drm:__nv_drm_gem_nvkms_memory_prime_get_sg_table like this:
https://gitlab.gnome.org/GNOME/mutter/-/issues/1891
Did you start the wayland session on purpose? Otherwise, try disabling wayland:
https://linuxconfig.org/how-to-enable-disable-wayland-on-ubuntu-20-04-desktop

No, I did not start wayland. Disabling it worked. Thanks Mart and generix!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.