Only integrated screen on Ubuntu 18.04.02 LTS with GTX 1060 3GB

Hi there! I’ve searched and tested a couple thousand things and i cannot get trough this, so i’m posting here hoping that someone can help me :)

I have an MSI GP62MVR 7RF (Leopard Pro), with a GTX 1060 3GB. On Windows everything works as its supposed to, but on Linux (Ubuntu 18.04.02 LTS, kernel 4.15.0-46, nvidia driver 390.77) it only lets me use the laptop screen, using Nvidia (Performance Mode) or Intel (Power Saving Mode). In nvidia-settings it only shows “PRIME Displays: eDP-1-1” and so i cannot use HDMI. I’ve tried switch to open source driver (nouveau) and that way the only output is HDMI -_-

Can anyone help me?

Cheers

nvidia-bug-report.log.gz: https://drive.google.com/file/d/1pw5VdofNG7PIbzYUnoYh0T2i_NKAZU-Z/view?usp=sharing
xrandr-info: https://drive.google.com/file/d/1FwbmHTb-4DORleYdySE2EJ2P41KtOcXe/view?usp=sharing

I suspect that you ran into a known rare bug of the nvidia driver. First of all, please add the Ubuntu graphics ppa and install the latest driver (415) from that. If that doesn’t make the HDMI output work, use this workaround:
run

grep modeset /etc/modprobe.d/* /lib/modprobe.d/*

to find the file containing

options nvidia-drm modeset=1

and change it to

options nvidia-drm modeset=0

then run

sudo update-initramfs -u

and reboot. Leads to tearing on the internal screen, though.

Thanks for the quick answer!

I’ve upgraded to 415 version but it happened what already happened before with other driver versions / kernel versions / brain versions :)

it freezes on login. After a couples tries i’ve logged in via tty and removed ppa / downgraded back to 390.77. everything as before, now :)

About the rest of your answer, i’d like to not to do that, since screen tearing sucks (:D) and will affect my daily work.

Cheers

Then you should rather look into why newer drivers don’t work, install the 415 driver and then run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

Ok, this is odd. I’ve again upgraded nvidia driver to 415, but this time i was able to login without problems.

Despite that i’m still only able to see “screen 0” and “edp1-1” on xrandr output, so i’m attaching new nvidia-bug-report ;)

Cheers
nvidia-bug-report.log.gz (1.05 MB)
xrandr_output.png

Can you at least check if this is caused by the modeset=1 setting?

I just noticed that the Xorg.0.log in the log files was some old one which didn’t show any connected monitor. So it might be that GDM is running on Wayland which disables the additional outputs on the nvidia gpu. Please check if this helps:
https://askubuntu.com/questions/975094/how-to-disable-wayland-in-17-10-in-gdm3-login-screen

I’ve uncommented that line and restart computer, session shows like “x11”, but xrandr still show no other outputs :(

It’s about the gdm session, not the user session. Furthermore, your xrandr output now shows edp-1 instead of edp-1-1 which points to now only the intel gpu being active.

You are right, it was on Intel.

I’ve changed back to Nvidia GPU but xrandr is the same as before, and now my screen freezes every 10/12 seconds :/ It completely freezes (i cannot type, move the mouse and seconds counter freezes too)
nvidia-bug-report.log.gz (995 KB)

I’m sorry, i didn’t saw this! I’m going to check it now

NO WAY! It’s working! I am now using Wayland (i had changed back to keep working :D) and i have all the outputs (and, ofc, HDMI is working).

Can you briefly explain why?

Thank you very much for the help!