Logitech F710 does not show up in /dev/input

I am attempting to install a Logitech F710 with Jetpack 6.0 production but it will not show up in /dev/input
In previous jetpacks it would show up as /dev/input/js0

dmesg shows it is being connected:

[ 810.639936] usb 1-2.1: new full-speed USB device number 6 using tegra-xusb
[ 810.811021] hid-generic 0003:046D:C22F.0003: hidraw2: USB HID v1.11 Device [Logitech Logitech Cordless RumblePad 2] on usb-3610000.usb-2.1/input0
[ 810.814804] hid-generic 0003:046D:C22F.0004: hidraw3: USB HID v1.11 Device [Logitech Logitech Cordless RumblePad 2] on usb-3610000.usb-2.1/input1

and lsusb also shows it connected:

Bus 001 Device 007: ID 046d:c21f Logitech, Inc. F710 Wireless Gamepad [XInput Mode]

These are not working on the Orin AGX Dev Kit or a Orin NX on a seeed studio board.

Can anyone help with resolving this or has anyone resolved this before? I have attemped to customize the kernel but it didn’t help. I also don’t think it would make sense I need to customize a kernel to get this typical joystick to work as it has in previous jetpacks.

1 Like

A user shares a method:
Jetpack 6.0 - issue with xbox gamepad - #4 by as_lab

Please give it a try.

I tried that and it didn’t work for me.

1 Like

I am also encountering the same issue with the Logitech F710

Please check this:
GitHub - jetsonhacks/logitech-f710-module: Support for Logitech F710 game controller on Jetson Xavier

The method is for Xavier. Please take a look and try to apply it to Orin.

Thank you very much for your assistance.
However, after following the README of that repository, I encountered an issue:

logitech-f710-module$ ./install-module.sh
Installing on root device: /dev/nvme0n1p1
Installing from: bin/l4t-36-3-0
./install-module.sh: line 27: cd: bin/l4t-36-3-0: No such file or directory
modinfo: ERROR: Module hid-logitech.ko not found.
The Kernel version does not match the Module Version
Kernel Version: 5.15.136-tegra
Module Version:
Would you still like to install the module? [Y/n] Y
You may have to force the module to be inserted, i.e.
$ sudo modprobe -f hid-logitech
cp: cannot stat ‘hid-logitech.ko’: No such file or directory
Installed hid-logitech Module

logitech-f710-module$ ./build-module.sh
Cannot find kernel source in /usr/src/.
You will need to install the kernel source before proceeding.

Has anyone resolved this issue before?

This also did not resolve it for me. I had tried that before.

Currently, I am using a PS4 gamepad as a replacement for the Logitech F710. My customer can connect to it via the GUI or command line (using bluetoothctl) or cable. I hope the new version of Jetpack will be released soon and fix this issue.

This is a community contribution and the author has updated to r35.5.0:
Add l4t-35-5-0 · jetsonhacks/logitech-f710-module@8499969 · GitHub

May see if Jetpack 6 will be included in the future.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.