Logitech G29 wheel & Pedal not working

I’m trying to use a Logitech G29 driving force racing wheel with the Jetson Nano on the USB port.
The G29 is recognized by lsusb, and then input device is created. (/dev/input/js0)
However, G29’s Wheel and Pedal is not working on jstest-gtk. Button only is working.

My PC was same problem, too. OS is ubuntu 18.04
I solved as follows on PC.
$ sudo apt-get dist-upgrade.

I can’t solve in the above method on Jetson Nano.
How can I solve it on Jetson Nano? <<-- Solved

I downloaded L4T Sources and reinstalled device driver.
Is there a case that device driver does not operate normally in the initial state of SD Card Image?

lsusb_g29X.txt (2.34 KB)

Some controllers require a custom driver. If you run “lsusb”, and get the ID of any device which doesn’t work, you can then do a verbose listing of that device and post the content here. The content should help narrow down if it is just a missing driver. Your ID will differ, but will look something like “0955:7020”. The verbose query would be like this (substitute the actual ID):

sudo lsusb -d 0955:7020 -vvv

Note that if you hover your mouse over the quote icon in the upper right corner of one of your existing posts, then other icons will show up. The paper clip icon is for attaching files (or you could just paste it in as code).

The lsusb message is shown below.
Only Buttons works, Wheel and Pedal do not.

Bus 001 Device 007: ID 046d:c294 Logitech, Inc. Driving Force
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               2.00
  bDeviceClass            0 (Defined at Interface level)
  bDeviceSubClass         0 
  bDeviceProtocol         0 
  bMaxPacketSize0        16
  idVendor           0x046d Logitech, Inc.
  idProduct          0xc294 Driving Force
  bcdDevice           13.50
  iManufacturer           1 Logitech
  iProduct                2 G29 Driving Force Racing Wheel
  iSerial                 0 
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength           41
    bNumInterfaces          1
    bConfigurationValue     1
    iConfiguration          4 U89.00_B0025            
    bmAttributes         0x80
      (Bus Powered)
    MaxPower               98mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           2
      bInterfaceClass         3 Human Interface Device
      bInterfaceSubClass      0 No Subclass
      bInterfaceProtocol      0 None
      iInterface              0 
        HID Device Descriptor:
          bLength                 9
          bDescriptorType        33
          bcdHID               1.00
          bCountryCode           33 US
          bNumDescriptors         1
          bDescriptorType        34 Report
          wDescriptorLength     157
         Report Descriptors: 
           ** UNAVAILABLE **
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0040  1x 64 bytes
        bInterval              10
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x01  EP 1 OUT
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0010  1x 16 bytes
        bInterval              10
Device Status:     0x0000
  (Bus Powered)

According to this the device is recognized as a standard human interface device. Drivers should be able to handle this. There is a twist on the story though when it comes to force feedback: Other user space software may be required in order to utilize this. Buttons are simple and always have HID drivers and software, so those are never a problem. I don’t have one of these, but if you can find out what software a desktop Linux PC uses in order to interact with the force feedback side, then installing this on the Nano will probably do the job.

Excuse me,has the problem been solved?I had the same problem

I solved by reinstalling the device driver.
You can download L4T Jetson Driver Package.

Hey, Friends. I met the same probelm with you, your suggestion is well, but I am a beginner, I am wodering what to do next after I have downloaded the L4T Jetson Driver Package. Would mind giving some details, and if it is possible would you mind sending me a e-mail at 670557192@qq.com. Thank you very much, waiting for your replay.

Best wishes.