Ls /dev/video0 is No camera available

Hi every one,

I am working on jetson nano module, with jetpack 4.6. Currently jetson working via, ssd card 64 gb. Before coming to me OS is installed on EMMC (16gb) but I made it OS to SSD card by changing the boot file.

I have tried to reinstall ardcum files for driver files but files are existed.

nvsgcapture, gstream is not working while access the camera via import cv2, no camera avaiolable.

After installtion of opencv, tensorflow, mtcnn. I am unable to accessing the camera.

Camera access is compulsory for my project.

Looking forward for your reply.

What’s the sensor? Did you try jetson-io to configure the sensor?
Does /dev/video0 present?

Thank you for reply.,
The sensor is Raspberry Pi Camera V2.
Yes I have run file. When running that file the io screen is flashing on/off instantly.

Looking forward for your needy help and/or suggestions,
Thank you

Hello sir/madam,

When I am running this: sudo /opt/nvidia/jetson-io/

terminal header tool screen is getting on/off in short period.

sudo /opt/nvidia/jetson-io/

Traceback (most recent call last):
  File "/opt/nvidia/jetson-io/", line 84, in <module>
  File "/opt/nvidia/jetson-io/", line 39, in main
    jetson = board.Board()
  File "/opt/nvidia/jetson-io/Jetson/", line 229, in __init__
    self.dtb = _board_get_dtb(self.compat, self.model, dtbdir)
  File "/opt/nvidia/jetson-io/Jetson/", line 114, in _board_get_dtb
    raise RuntimeError("No DTB found for %s!" % model)
RuntimeError: No DTB found for NVIDIA Jetson Nano Developer Kit!

Please reference to below.

Hello sir/madam,
I am using Jetpack 4.6 not jetpack 4.3. Please suggest some better suggestions.

I have tried as per the suggestions given in this link : JetPack 4.3 - L4T R32.3.1 released - #15 by jonathanh
But still the problem not solved, Failed to open /dev/video0: No such file or directory

Did you able run the jetson-io?

yes, but the terminal screen is getting on/off.

Did you use sdkmanager to flash the system?
Please try on latest release.

Thank you for your reply,

No, we have received it from the vendor with os of ubuntu 18.04. We don’t know how they did. Currently it is running with jetpack 4.6.
When we are trying to flash the image on new jetson nano (another device) using sdk manager from the host machine(ubuntu 18.04), os is able to flas but fails to install cuda tools and says incorrect username and password (automode and even in usb cable also).

Please create new topic for the cuda things.

ok, could you please suggest about camera no available (ls /dev/video0), afte running this command on terminal because I have installed packages in sdcard. I can’t reflash it.

I would suggest consult with Arducam for the driver/device tree integrate for enabling the sensor.

ok sir/madam, thank you

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.