Making a Thermal GMSL camera using a FLIR sensor


I am working for FLIR Systems adding one of our Thermal Cameras to the PX2 eco-systems.
It is working nicely using USB , just the capture, but there are some issues when using the GMSL.

We have a Visible GMSL camera that works, but ours doesn’t. I got some NVIDIA documents recommending to add some SCOPE probes in the PX2 HW but I am afraid of doing that… not sure if it is possible since my kit has this giant sinks, etc.

Has someone done this before? It doesn’t sounds as a good idea, not sure why NVIDIA proposed this.

A second question that I have is:

  • in order for nvmimg_cc to work, is it really needed to have the FSYNC_LOCK bit activated? Maxim is saying that for one camera doesn’t make sense… but I see this activated In all the GMSL cameras even if I run just one.

I was able to go further and activate that BIT by making FSYNC manually… which again , not sure if makes a difference but I was able to go further in the error messages…

Now I am getting :

Capturing Frames …
CaptureGetErrorStatus: ChanselFault: stream=0 vc=0 frame=1 data=0x01000040 SofTs=3768662940 ErrTs=3769107367
nvmedia: ERROR: _CaptureThreadFunc: NvMediaICPGetFrameEx failed

that looks like it started to get a frame and then failed?
before I was just getting a Timeout error after retying 11 times (default number in the source code)

I met similar problems when I tried to enable GMSL camera. I have two questions:

  1. How did you activate FYSNC manually?
  2. Did you solve the error “CaptureGetErrorStatus: ChanselFault: stream=0 vc=0 frame=1 data=0x01000040 SofTs=3768662940 ErrTs=3769107367”?
  1. I did that touching the xx.script that has the deserializar / serializer configuration. Very specific to the camera hardware.

  2. yes. My problem was that i had one extra line of video. As soon as i put the right video frame size in the xx.script then it started working.

Thanks for your reply.
Where do you set the right video frame size in xx.script, capture config parameter at the top of script or sensor register in the middle of xx.script? If you changes the sensor register, which register did you modify? Is the video frame size related to embedded bottom/top line?

Do you have any experience on AR0132 sensor?

I am facing a similar situation when trying to enable our own GMSL camera using Maxim9876 deserializer - running the nvmimg_cc with our own script:

nvmedia: ERROR: _CaptureThreadFunc: Keep failing at NvMediaICPGetFrameEx for 11 times

Any help is appreciated. Thanks !!

In my case was a matter of selecting the right settings for the SER / DES and the image size, since our sensor has some special things.

However, with the new PXDrive SW we are having some other issues as you do, so at this point I don’t have valid information to share.

Hi AndresPMT,
Can you share what kind of SER/DES where you using for your application ?

Deserializer: The one at NVIDIA PX2: Maxim9286
Serializar : Inside our camera : Maxim96705

Our sensor is RAW14 (we had to change NVIDIA SW).