Hello Everyone.
Perhaps this topic doesn’t join here but I need your help guys.
I’m new in ROS. Basically I’m looking for a tutorial to run mavros.
I am using a Jetson TX2 and I have already installed ROS and MAVROS.
I have the pixhawk 4 connected to Jetson via Telem port 2.
I want to know step by step how to control the drone with MAVROS for instance: go up, down, left, right, go ahead and back.
I don’t want to use the gazebo, I want to run a test in my own drone that I have.
Please, I ask for help to the community.

Hi alberto18_90, although I am not sure of the specifics of using MAVROS, my understanding is once you have the MAVLink connection between your Jetson and PX4, MAVROS should be able to function normally with ROS installed (hence you may want to consult the MAVROS documentation).

Perhaps others from the community may be able to lend their experience with MAVROS. In the meantime, here are some related resources:

Thank you so much. Now I’m able to run MAVROS but it seems that Jetson is not sending data from the serial port.
How can I see if the serial port /dev/ttyTHS2 is sending data? Btw I’m using the orbitty carrier board.

Hmm, you might be able to try a serial port sniffer such as interceptty:

(there are other suggestions included in the bottom link that you may want to try as well - I was able to build interceptty but haven’t used it before)

You might want to contact ConnectTech Support to see if you need to do anything else to use that port from the Orbitty carrier. Have you tried using the serial port otherwise (i.e. connected to a PC) to confirm that you can send/recieve data on it?

Have you tried using the serial port otherwise (i.e. connected to a PC) to confirm that you can send/recieve data on it?

No, I have not tried. How can I connect to a PC and send data?

Check with ConnectTech which UART adapter they recommend for connecting the Orbitty’s serial port to a PC, then you could use a program like screen, minicom, or putty to connect (or with C/C++ or Python code):

See this JetsonHacks article that does it with a TX2 devkit:

thank you for your answer.
I’m still not being able to connect.
I realize that the problem is that UART 1 is not sending anything. says “UART 1, under L4T this port will show up as /dev/ttyTHS2”
I followed the JetsonHacks article and I couldn’t connect the TX2 with the PC. I realize that I have to install something but I don’t know…
Just I want to make a test send and receive data.

OK, gotcha. If we take a quick step back, if you have a TX2 devkit carrier, can you try to reproduce the JetsonHacks setup with your devkit?

It seems the problem is in the Orbitty carrier board.
I put back the TX2 into the devkit board and the connection is working…
I’m waiting for the answer of

[ INFO] [1474199233.588586444]: Plugin safety_area blacklisted
[ INFO] [1474199233.600930025]: Plugin setpoint_accel loaded and initialized
[ INFO] [1474199233.641511189]: Plugin setpoint_attitude loaded and initialized
[ INFO] [1474199233.661666017]: Plugin setpoint_position loaded and initialized
[ INFO] [1474199233.694834938]: Plugin setpoint_raw loaded and initialized
[ INFO] [1474199233.704689855]: Plugin setpoint_velocity loaded and initialized
[ INFO] [1474199233.724599062]: Plugin sys_status loaded and initialized
[ INFO] [1474199233.736115519]: Plugin sys_time loaded and initialized
[ INFO] [1474199233.740434731]: Plugin vfr_hud loaded and initialized
[ INFO] [1474199233.740528115]: Plugin vibration blacklisted
[ INFO] [1474199233.769315690]: Plugin vision_pose_estimate loaded and initialized
[ INFO] [1474199233.782049265]: Plugin vision_speed_estimate loaded and initialized
[ INFO] [1474199233.794921798]: Plugin waypoint loaded and initialized
[ INFO] [1474199233.795055129]: Autostarting mavlink via USB on PX4
[ INFO] [1474199233.795149972]: Built-in SIMD instructions: None
[ INFO] [1474199233.795204867]: Built-in MAVLink package version: 2016.5.20
[ INFO] [1474199233.795247418]: Built-in MAVLink dialect: ardupilotmega
[ INFO] [1474199233.795292522]: MAVROS started. MY ID 1.240, TARGET ID 1.1
These are what I got. It does not seem to receive heartbeat.

I’m working in the devkit but still cannot connect to the PiXhawk 4
I follow varios tutorials that you send me…

I follow also this tutorial… I did the same but don’t have results

I found the problem.
I posted a guide in my github:

Hi alberto, thanks for posting the solution to your comprehensive GitHub repo. I’ve added it to TX2 wiki here:

Hi there,
I have same issue right now and even I cant resolve when I follow this link. I really need help.

Hello! It is been a long time since I did not read this article. In my case I am using the orbitty carrier board for Jetson TX2. And right now I have installed again Mavros, May I know where are you facing problems?