Maya fails to import Maya geometry cache

Hi all,

I am getting frustrating failure of Maya to properly open the Maya geometry cache files with the following message:

file -import -type “USD Import” -ignoreVersion -ra true -mergeNamespacesOnClash false -namespace “yodaheadonlyhighresresult” -options “apiSchema=;assemblyRep=Collapsed;chaser=;chaserArgs=;excludePrimvar=;importInstances=1;importUSDZTextures=0;importUSDZTexturesFilePath=;jobContext=;metadata=[hidden,instanceable,kind];preferredMaterial=none;useAsAnimationCache=0;readAnimData=0;useCustomFrameRange=0” -pr -importFrameRate true -importTimeRange “override” “C:/Users/spltechdesign/Desktop/yodaheadonlyhighresresult.usd”;
// File read in 3.1 seconds.
select -r polySurface3_result ;
// Error: y_derger_1_polySurface3_resultCache1 (Cache File): D:/NoYO/y_derger_1_polySurface3_result may have an invalid cache description or invalid, missing or empty cache file.
Cached Playback: The presence of unsupported Cache File node ‘y_derger_1_polySurface3_resultCache1’ has triggered Safe Mode, and caching is disabled.
You can continue work, but caching has stopped.
Remove animation from ‘y_derger_1_polySurface3_resultCache1’, or delete the node entirely, to resume caching.

I tries re-installing both Audio2Face and Maya, I get the same result. Using the demo file does import a cache file just fine in Maya. I am on Windows, now Maya 2023, I was using 2022, but get the same message.

I tried once the whole body and then made just the head. I have used this app before, I don’t know why it is now not letting me load the cache files. I can send you my file if you wish.

Thanks,

John A

You can attach file here and we can take a look. It is most likely geometry issue with combined meshes not welded.

Can you try running “Mesh Separate” in the drop down menu of your character mesh before setting up A2F for export and see if that helps?

Hi siyuen,

Thanks for your answer, I tried Mesh Separate but nothing changed. I am using single meshes only every time.

Also I should say that it appears the node is added in maya, and the play head moves slowly as if it’s under load, but the mouth doesn’t move on the mesh. It’s as if it’s playing a huge cache file that doesn’t really have animation.

If I upload my file here, can only you get it, or would it be available to anyone on the forum? I am not able to distribute this geometry beyond support.

You can send me a Direct Message on the forum so is not public

Send the USD file, that should be enough.

Thanks for testing the Mesh Separate. Reading your last reply, I wonder if it is caching out the wrong geometry. Send the file over and we can take a look. Thanks

1 Like

HI siyuen, Thank you, thank you, am trying just at few more things here and then I will get my file to you.

1 Like

Hi siyuen,

I have kept working on this and testing and clearly my mesh is too high in polys or some other mesh issue exists. I returned to the low res mesh that works and loads cache files from Audio2Face and into Maya just fine. Now I wrap the higher resolution geometry to this and it is working pretty well on my first successful test.

I do need to determine how to host the entire high-res character in Audio2Face with the skeleton andimport mixamo animations in order to make an Omniverse version. thanks

Hi siyuen,

Here is the result I made with wrap:

Meta Yoda Audio2Face Test

Can you send me new emotion version to test? Can I be a tester?