Audio2face to Maya Geometry Cache Issues

Hello everyone

I’m trying to use Audio2face since yesterday and everything was ok until I tried to import my animation into Maya.
I watched the videos and did the final export as Maya Cache but when I import my Geometry cache the character vertex goes glitchy

Also i can see the glitchy head moving as the animation but as you can see it’s too glitchy i can’t use it.
So i’m asking for help if someone has an idea about this issue
thank you


Most likely you pick the wrong mesh to export in the export UI. Make sure is the Target mesh with the “_result” mesh at the end that you are exporting and that your mesh in maya applying the cache is same mesh (with same vert ID order) Try and make sure that is the case.

Well i’m using the _result mesh thats why its weird, also I tested on your basemesh on maya and its working well

I tried with others mesh too and its still glitchy

That is odd and we have not seen this. Can you upload your mesh here or DM me so we can try it on our end and see.

It is usually pretty straight forward, if is the same mesh, the cache should load, never have had the this issue when the right mesh were picked and exported.

Did you export USD or Maya cache or you try both with same result? Can you try USD cache and see if it works too? Curious.

The holes in eyes should not matter

Hey, I’ve found a way to make it work, exporting my base mesh from maya in USD directly with the USD Maya exporter plugin and its keeps the vertex order ;)

1 Like

I see, cool.

Yes I usually recommend using Omniverse Maya or Maya’s own USD exporter to export to USD. What were you using before that gave your messed up vertex order?

You should be able to export FBX from maya and import in A2F (with the asset importer extension loaded) to convert to USD from content_browser. Then load that converted USD. That should also work.

If some of these options are not keeping vertex order, let us know and it might be a bug we want to fix. Thanks