Metahuman characters eyes are texture is mapped a wrong way

See, my ( default famale ) Metahuman project export from 4.27 UE, in Create.

The eyes texture is mapped in a wrong way. Why? HOw can I fix this the right way?

I also do not get hair imported. I know it is still a work in progress, but some workaround would be great. Activating the Groom plugin in UE 4.26 and exporting with connector did not gave me the hair. Not in the View app either…

  • ** Eye texture:**

    • I was able to edit the PupilShiftY material parameter to align the pupil to where I wanted it. I haven’t tried a y-up stage export, though this should work correctly. Let me know if this parameter doesn’t work for you or if you used a y-up export.
    • Note that if the max values don’t work for you this can be overriden with a Ctrl+click then input the value you’d like (I did this with 4.0)
  • ** Hair in Create:**

    • I don’t have a workaround at the moment, and yes, BasisCurve support is coming. The Groom plugin is probably exporting the curves correctly, but Create just doesn’t render anything for it. I can see it in the Stage tab.
      image

    Our expectation here was if a tool could render them then we’d be ready. For instance, all of the groom exports are available in USDView:

    I also imported it into Blender and I see the BasisCurves there too:

1 Like

Great thanks Lou!

I continue from here when we get the hair renderer…