MHEA28-XTC on Windows Server 2012 R2 and Windows 7


I’ve just received two of these cards (MHEA28-XTC) and popped them into a workstation and a server, the goal is a 10GbE connection between the two.

After installing Win_OF I get code 10 errors in the device manager, saying the device won’t start, I’ve tried several drivers that come with the Win_OF package but none seem to get past error 10.

Someone on here had the same error with a different card, and updating the firmware was suggested, so after trying MFT3.8.0 and figuring out that it doesn’t play nicely with these cards I reverted to MFT2.7.1. Using Mlxburn in the package I wrote the 5.3.000 firmware to the card, after this I still get error 10 (device can’t start)

After trying to query the firmware version on the card, the machine froze up and only came back to life after pulling it’s power plug, so I guess there’s something there…

Anyway, can these cards be made to work in Server 2012 R2? It’s for a test lab not production so even if it requires a ‘shady’ workaround that’s fine.

Hopefully somebody can help me,


Not sure if these will run on the ESXi driver, won’t hurt to give it a try.

As far as I know they’re only certified work on Linux boxes

It’s been a while and I had given up on these cards but last week I received two new servers and saw the cards laying on the shelf and figured I’d give it another go.

Figured I’d post my results here if anyone ever tries these cards too.

After trying four or five different drivers (and having to disable driver signature checking every time + rebooting) so about 2 hours later… The card showed up under Device Manager with the proper name but still a yellow triangle.

(Again code 10…)

I installed WinOFED 2.3 (not the latest version) after extracting the MSI installer to XML and removing the check for 2008 R2 and repackaging it and 2 new NIC’s showed up (OpenFabrics IPoIB Adapter 1 and 2).

After configuring the IP’s for the ports and running opensm the first port came up and now handles traffic from one server to the other (and the other way).

So at least it is possible and I couldn’t be more happy.

But as I’ve come this far, I want that second port to start working too…

I’ve figured out I need to configure opensm to run for both port GUIDs, but so far I’ve only found commands for Linux which as it is on Server 2012 R2 don’t really help.

So if somebody here knows how to set opensm up please let me know.

Btw, the plan with ESXi was to pass the cards to a Solaris VM using Vt-D as Solaris would work with the cards and then bridge them to a virtual switch back to the other VM’s, which was just a desperate attempt to get something out of these cards, but I never got to do it as ESXi refused to let me play with PCI passthrough So I don’t know if ESXi will run these cards, Windows Server 2012 R2 will, with some effort and so far only 1 of 2 ports.

EDIT: Figured it out, ‘opensm --guid xxxxxxxxx’ was what I needed, after adding 2 services (one for each port) on each server the cards come online on every boot and work flawlessly


These cards are really old, older than the first WinOFED driver. I don’t think these will work on your OS. code 10 is a generic windows error on driver compatibility and can generate from various of reasons.

Allright that’s a downer… Anyway I’ll pop them in the vSphere machines then and work with them that way (if they run on ESXi 6?).