mlnx-ofed-kernel installation failed!

Hi All, We are trying to install Mellanox and getting “mlnx-ofed-kernel installation failed!” issue. Need your support to resolve the issue.

Followed below steps:

  1. Install the libverbs library using the below command. apt-get install ibverbs-utils

  2. Download the latest Mellanox OFED/EN as below. The version in the example may vary. This can be found from the Mellanox site

Ex: wget http://content.mellanox.com/ofed/MLNX_OFED-5.0-1.0.0.0/MLNX_OFED_LINUX-5.0-1.0.0.0-ubuntu18.04-x86_64.tgz

  1. Install the above package using the below command in the base directory of the package.

./mlnxofedinstall --upstream-libs --dpdk

Error: mlnx-ofed-kernel-dkms installation failed!

Collecting debug info…

See:

/tmp/MLNX_OFED_LINUX.26945.logs/mlnx-ofed-kernel-dkms.debinstall.log

/tmp/MLNX_OFED_LINUX.26945.logs/mlnx-ofed-kernel-dkms.make.log

Removing newly installed packages…

Note: Please find the hardware details:

Model no: CX516A

HCA---->ConnectX®-5/ConnectX®-5 Ex (50GbE)

mlnx-ofed-kernel-dkms.make.log (82.3 KB)

mlnx-ofed-kernel-dkms.debinstall.log (82 KB)

Hello Ravi,

Thank you for posting your inquiry on the NVIDIA Networking Community.

Based on the information provided, this is a known issue when trying to install this version of MLNX_OFED 5.0 on the newer kernel versions provided by the Linux distro (>-66).

This issue is resolved in the latest MLNX_OFED GA version, which is version 5.3

You can download the latest version through the following link → https://www.mellanox.com/products/infiniband-drivers/linux/mlnx_ofed

Thank you and regards,

~NVIDIA Networking Technical Support