Modules not found - Nvidia Modulus

Hi, I could run some of the examples within the Modulus Container (22.03.1)
I tried to write my own code, Iwas going to do it step by step, first by running an empty solver based on a custom pde class, that contains just a print(“test”)).
But I received a couple of errors: ModuleNotFoundError: …
after modifying some of the imports I still get the error for other module (geometry.primititves_1d)

(
what I have modified and apparently worked:
from modulus.hydra import to_absolute_path, to_yaml, instantiate_arch, ModulusConfig

from modulus.hydra import to_absolute_path, to_yaml, instantiate_arch
from modulus.hydra.config import ModulusConfig
OR:
modulus.solver import Solver → modulus.continuous.solvers.solver import Solver
)

I would like to ask where can one read about the () changes between versions?
There is a previous answer

But I am not able to acces the material in gitlab, I have already submitted the form , but is not possible to edit it in case I made some mistake.

Thanks in advance.

Hi @dan.m1

We had a large restructure of imports in 22.07 release to hopefully make import statements a little more concise. Thus we recommend using the 22.07 container if possible.

Is there a reason you’re using the 22.03.1 container? If you were having trouble with 22.07 we have reuploaded the 22.07 container to devzone image. Please give it another download if possible and let me know if it doesn’t work still.

We also provide Modulus containers on NGC which can also be pulled as an alternative option: Modulus | NVIDIA NGC

We are looking into the permission issues regarding Gitlab.

1 Like

Hi @ngeneva ,

Thanks.
I am using the 22.07 container and now the import is working. Also I’m able to read the material.

1 Like