Monitor BLS3393 Constantly Blurry In Linux but not in Windows 10

I’ve been having this issue for at least 3 years where my display will be blurry while using the proprietary Nvidia driver. Nouveau doesn’t fix anything either.

Any screenshots that I take using the monitor will show up crystal clear, but visually looking at it, everything seems fuzzy, blurry and sometimes even ghosts if I move a window around. I have a second monitor plugged in via a DP->VGA adaptor and, even when my main monitor is blurry, that looks perfectly fine. Sometimes my monitor will work flawlessly, but that’s once in a blue moon.

I’m currently running Void Linux with the latest Linux kernel and KDE Plasma.

I am using an Nvidia RTX 2060, and the monitor is getting the signal via HDMI. I am unsure of the monitor’s control board and anything like that as it’s a seemingly random brand that have no official datasheets (and it doesn’t even seem to be sold anymore). What I do know is it’s a 32" 1080p@60Hz display, and it won’t go higher than that.

I don’t have this issue on Windows 10, and everything is displayed crisp and clear as day.

Here are some troubleshooting steps that I have taken:

  • Tried GNOME, KDE Plasma and even XFCE - all produce the same output
  • Swapped the HDMI cable and even bought a whole new one
  • Tried changing the HDMI port that I use on the monitor
  • The issue has persisted across two GPUs now (I used to use a GTX1050)
  • Reinstalling the Nvidia Linux drivers (and reconfiguring them). They show up in lsmod and X11 is set to use them - nouveau is blacklisted and I confirmed this with lsmod
  • The issue has persisted over many distros, such as Ubuntu, Pop, Arch, Gentoo and Void.
  • I have looked in the monitor settings and found nothing relevant, and changing everything I can see does nothing to fix the clarity either
  • I’ve looked high and low in Plasma’s and Nvidia’s settings, and tried things such as forced anti-aliasing, text rendering, and even vsync changes. They make no difference even after a save + reboot.
  • I’ve installed every (even seemingly) relevant package across every Linux distribution that I’ve used, and none of them made a difference.
  • I re-tried POP_OS and ensured that I was using the Nvidia ISO and installs to root out any misconfiguration, to no avail.
  • Ensured that FXAA was disabled in the Nvidia settings
  • I can view a full 1080p image in Firefox while using F11, with no vertical/horizontal scroll bars
  • I have checked through the nvidia log file (the one you’re able to generate manually) and found nothing that seems to relate to my issue. nvidia-bug-report.log.gz (215.8 KB)

It’s probably important to note that, in a live Linux ISO, if I change my output to a lower resolution and then back to native a good 5-8 times, the monitor will clear up. This is not a permanent fix but I think it has something to do with the connection being re-initialised, although I’m not too sure about the reason.

I have looked around for others that have experienced something similar to me and all of the issues turned out to be misconfiguration or things that had nothing to do with what I’m experiencing (mostly anti-aliasing issues).

I find it hard to think of things that could be at fault as it works perfectly fine in Windows, which is baffling to me. In addition to this, when I ran Windows under Linux via KVM+QEMU (with Single GPU Passthrough), all the issues went away as the drivers were handled by Windows.

“bls-bls3393” is the closest match to my monitor I can find online, except mine is 32" and not 19". I can’t post anymore links in here due to being a new user.

Here is an output of xrandr:

Screen 0: minimum 8 x 8, current 3360 x 1179, maximum 32767 x 32767
HDMI-0 connected primary 1920x1080+1440+0 (normal left inverted right x axis y axis) 376mm x 301mm
   1920x1080     60.00*+  59.94    50.00    23.98  
   1680x1050     59.95  
   1440x900      59.89  
   1280x720      60.00    59.94    50.00  
   1152x864      60.00  
   1024x768      60.00  
   800x600       60.32    56.25  
   720x576       50.00  
   720x480       59.94  
   640x480       75.00    72.81    59.94    59.93  
DP-0 connected 1440x900+0+279 (normal left inverted right x axis y axis) 408mm x 255mm
   1440x900      59.89*+
   1280x1024     75.02    60.02  
   1280x960      60.00  
   1152x864      75.00  
   1024x768      75.03    70.07    60.00  
   800x600       75.00    72.19    60.32    56.25  
   640x480       75.00    72.81    59.94  
DP-1 disconnected (normal left inverted right x axis y axis)
DP-2 disconnected (normal left inverted right x axis y axis)
DP-3 disconnected (normal left inverted right x axis y axis)
DP-4 disconnected (normal left inverted right x axis y axis)
DP-5 disconnected (normal left inverted right x axis y axis)

Here are two previews of google, this is windows and this is Linux. I know the differences aren’t too perceivable on camera, but they are to the naked eye. Looking at it more, it seems that the output is also heavily under-saturated while in Linux.

I have also asked this on StackExchange and I was referred here by a commenter.

Just as an additional comparison, I ran this sharpness test on both Windows and Linux.

Here is Windows, and here is Linux.

These were taken from roughly the same distance, height and angle. On both OSes, my second monitor looks perfectly fine - it’s just my main monitor on Linux that’s the issue.

I didn’t choose this test as an actual “sharpness test,” it was mainly so you could see the differences between the two operating systems.

I have also found very similar issues here:

These are just a few of the posts I’ve came across that have similar issues to what I describe.