Nano 2gb with RPi V2 camera not working

I installed a new RPi V2 camera to my Jetson Nano 2gb Development Kit. ls -l /dev/video0 worked as it was supposed to do. Then I tried “gst-launch-1.0 nvarguscamerasrc sensor_id=0 ! nvoverlaysink”, a very fast window border came up and went away. Now, even ls -l /dev/video0, does not work. I tried everything I could think of including re-installing OS on the SD card, tried it before the updates and again after. I think the camera blew up!

hello howdyrichard,

there’s erroneous in your pipeline, it’s sensor-id instead of underline to specify the index of camera sensor.
you may check this with $ gst-inspect-1.0 nvarguscamerasrc
for example,

  sensor-id           : Set the id of camera sensor to use. Default 0.
                        flags: readable, writable
                        Integer. Range: 0 - 255 Defaul

please also refer to Approaches for Validating and Testing the V4L2 Driver session, which show some sample commands for access your camera stream.

please gather logs for reference,
for example, you may check kernel messages ($ dmesg > klog.txt),
or, system level logs. ($ cat /var/log/syslog > syslog.txt) for more details.

Jerry - Thank you for that info. I did prove the camera module is defective. I bought another one and it works just fine so far with RPi2, so it should work with Nano.

hello howdyrichard,

yes, Nano is support RPiv2 camera sensor by default,
please follow the steps in post #3 to gather more details if you need further supports.

Thank you! I bought another camera and it works just fine.