Nano decode H264 error

hello , I have a problem about decoding frame in Nano,the solution is 1080p,when I run 00_video_decode.cpp of tegra_multimedia_api samples ,the error is nvDdkVicConfigure Failed,nvbuffer_transform Failed,Transform failed,
Howd Can I Solve It!!

Hi,
If you correctly install the samples through SDKManager, you should be able to successfully run the commands:

nvidia@nvidia-desktop:/usr/src/jetson_multimedia_api/samples/00_video_decode$ export DISPLAY=:0
nvidia@nvidia-desktop:/usr/src/jetson_multimedia_api/samples/00_video_decode$ ./video_decode H264 ../../data/Video/sample_outdoor_car_1080p_10fps.h264

thanks, but I try some 1080p h264 file ,it doesn’t work well ,also nvDdkVicConfigure Failed,nvbuffer_transform Failed,Transform failed, and how can I solve it!

Hi,
It looks specific to the h264 stream you have. Please attach it so that we can reproduce the error.

2.h264.log (470.7 KB) test.h264.log (3.6 MB)

These two h264 files in attachment is renamed *.log, you can rename it as another name, and I use 00_video_decode(the cmdline is ./video_decode H264 -o 1.yuv 2,h264) of Tegra_Multimedia_API_R32.2.0_aarch64, I hope you can tell me how to solve it ,thanks

you can rename these two files as 2.h264 ,test.h264

Hi,
We don’t observe the issue. It runs well.

nvidia@nvidia-desktop:~/jetson_multimedia_api/samples/00_video_decode$ head -1 /etc/nv_tegra_release
# R32 (release), REVISION: 3.1, GCID: 18186506, BOARD: t210ref, EABI: aarch64, DATE: Tue Dec 10 06:58:34 UTC 2019
nvidia@nvidia-desktop:~/jetson_multimedia_api/samples/00_video_decode$ ./video_decode H264 /home/nvidia/2.h264
Set governor to performance before enabling profiler
Creating decoder in blocking mode
Opening in BLOCKING MODE
NvMMLiteOpen : Block : BlockType = 261
NVMEDIA: Reading vendor.tegra.display-size : status: 6
NvMMLiteBlockCreate : Block : BlockType = 261
Setting frame input mode to 1
Starting decoder capture loop thread
Input file read complete
Video Resolution: 704x576
[INFO] (NvEglRenderer.cpp:110) <renderer0> Setting Screen width 704 height 576
Decoder colorspace ITU-R BT.709 with extended range luma (0-255)
Query and set capture successful
Exiting decoder capture loop thread
App run was successful
nvidia@nvidia-desktop:~/jetson_multimedia_api/samples/00_video_decode$ ./video_decode H264 /home/nvidia/test.h264
Set governor to performance before enabling profiler
Creating decoder in blocking mode
Opening in BLOCKING MODE
NvMMLiteOpen : Block : BlockType = 261
NVMEDIA: Reading vendor.tegra.display-size : status: 6
NvMMLiteBlockCreate : Block : BlockType = 261
Setting frame input mode to 1
Starting decoder capture loop thread
Input file read complete
Video Resolution: 1920x1080
[INFO] (NvEglRenderer.cpp:110) <renderer0> Setting Screen width 1920 height 1080
Decoder colorspace ITU-R BT.709 with extended range luma (0-255)
Query and set capture successful
Exiting decoder capture loop thread
App run was successful

You probably don’s get correct version of the samples. Suggest you install the samples through SDKManager. It handles version control of all packages.

Maybe the version is uncorrected,

head -1 /etc/nv_tegra_release

R32 (release), REVISION: 3.1, GCID: 18186506, BOARD: t210ref, EABI: aarch64, DATE: Tue Dec 10 06:58:34 UTC 2019

can you tell me the correct version ,thanks

Hi,
We are on the same version. Please check the log.
Do you run the samples in
/usr/src/jetson_multimedia_api/

I have no these firmware
nano@nano-desktop:/usr/src$ ls
linux-headers-4.9.140-tegra-linux_x86_64 linux-headers-4.9.140-tegra-ubuntu18.04_aarch64 nvidia
nano@nano-desktop:/usr/src$

I down the Multimedia API from there:

I’m so sorry, I find the version in my nano is uncorrect,

Hi,
Please install through SDKManager:

how to solve the problem. nano , jetpak4.2.2

how to solve the problem. nano , jetpak4.2.2
which jetpak version is OK?

how to solve the problem. nano , jetpak4.2.2
which jetpak version is OK?

Hi,
The rootcause is the versions of system and jetson_multimedia_api samples do not match. If you install all packages through SDKManager, it shall work fine.

you try not use USE_NVBUF_TRANSFORM_API mode.
if do not use USE_NVBUF_TRANSFORM_API mode, then is error

Hi,
Please use NvBuffer APIs, as suggest in this post.