New SDK manager can't flash TX2NX

I use the newest SDK manager to flash TX2NX. The Download is successful, but it can not flash.

Hello @AlfredNG

Did you unplug and plug the USB cable between step 1 and 2? We got the same problem when SDK Manager detected our device and then unplugged the cable and plugged it back in.

To solve this issue,

  1. return to step 1
  2. unplug the USB cable
  3. set your device in recovery mode again
  4. plug your USB cable
  5. Click “refresh” at step 1
  6. Continue to step 2

Hope it works

Last night, I followed your sets for several times and It didn’t work. When I restarted it, It always showed “cpu1 shutdown cpu2 shutdown” and auto power off.
Today in the morning, I power on, it s also shows “cpu1 shutdown cpu2 shutdown”, but it’s amazing that it can enter to the system and work

Interesting, I’m not sure what causes this. I hope it won’t cause this again.
Best regards

I don’t think cpu1/2 shutdown has anything to do with your issue.

CPU1/2 disabled is a expected one since we disable two cores on TX2 in default setting… and there are other cpu cores that are still alive.

Adding to what @WayneWWW is saying: The first CPU is CPU0, and this is the only one which is mandatory. Others are not used during boot. Of the other CPU cores CPU1 and CPU2 are normally reserved and you wouldn’t see those active unless you’ve taken steps to use them.

I‘m sorry! I check the file system carefully. I found that the previous files are still here. So I guess it just rolled back.

Here is my sdkm log.SDKM_logs_JetPack_4.6_(rev.1) (161.4 KB)

Is it a custom board or nv devkit?

No,the carrier is nano devkit’s.

  1. Is your nano devkit a B01 one?

  2. Have you tried sdkmanager 4.5.1?

1.Yes, it’s nano devkit B01.
2.what is sdkmanager 4.5.1? I just use SDK Manager 1.6.1 that is download from NVIDIA SDK Manager | NVIDIA Developer

Oh, sorry, should be jetpack4.5.1. You can select it in the sdkmanager.

I want to use the new jetpack. Because it support yuv444 encode and decode

What we are doing here is debug. Not really just ask you to use 4.5.1 and stay there.

No, I try it later.
Does tx2nx yuv444 encode and decode when it use jetpack 4.5.1 ?

TX2NX can’t work when I change to jetpack 4.5.1.
Here is the log.
SDKM_logs_JetPack_4.5.1_(rev.1) (199.8 KB)

Hi @AlfredNG ,

I just double confirmed that TX2 NX cannot use the jetson Nano devkit as carrier board. Need to use the NX one.

Is it correct?
It can be flash by old sdkm when I use nano devkit carrier board. But when I update sdkm, it does not work for tx2nx.
And I can’t find the old version of sdkm.
If I can setup the 4.6 jetpack for tx2nx, you can send me the older sdkm(similar 1.4)

please check below.

Sdkmanager version should not be the problem if you really understand how the flash work is done here…

Sdkm uses the driver BSP to do the installation… and this BSP won’t change when sdkm is upgrading…

For example, the “jetpack4.5.1” in sdkm 1.4.x is still the same one even when it is sdkm 1.6.x. Actually, I never really try to memorize the sdkmanager version… because there is no need to remember such number…