No audio playout in CloudXR 3.0 with Oculus Quest 2

I just upgraded to cloud xr 3.0 from 2.1 and tested it with oculus quest 2. But no audio was played out from the HMD.

1 Like

Hi @zidong.yzd - Can you please send us a copy of your logs so that we can troubleshoot with you?

Veronica

Try to join the server using only oculus quest, without connecting to the server with your PC at the same time.

I tried the soulution suggested by @andrey.otroschenko . The result was that if I started SteamVR using Microsoft Remote Desktop, the audio cloud be played out on the HMD. However, if I started SteamVR using VNC (and then closed VNC before using Oculus Quest 2), there was still no audio.

I will try to collect some log from android logcat.

I think there is something wrong with the virtual audio driver in CloudXR 3.0.

I replace it with the virtual audio device complied from GitHub - JannesP/AudioMirror: An audio driver for Windows 10 (only tested on x64) that works as a

The audio works now

Hi,

If I understand correctly, your server does not have any physical output devices correct? It sounds like the virtual audio device is not being created correctly, or it is disabled. When you use VNC, do you get windows sounds? RDP will create a virtual audio driver to pass the sounds of the computer you are connecting to back to you, which may be why it works with RDP but not VNC.

When you start the server from VNC, what playback devices do you see enabled/active in the Windows settings?

-Will

@wrice. Thank you for your attention.

  • your server does not have any physical output devices correct?
    No. I used a Windows VM from Alibaba Cloud without physical devices.

  • When you use VNC, do you get windows sounds?
    No. And I also tried to recorded audio from “NVIDIA Virtual Audio Device (Wave Extensible) (WDM)”, which was installed along with CloudXR 3.0. But nothing was recorded.

  • When you start the server from VNC, what playback devices do you see enabled/active in the Windows settings?
    Before I installed my own virtual audio device, it was “NVIDIA Virtual Audio Device (Wave Extensible) (WDM)”

Thanks. The “NVIDIA Virtual Audio Device (Wave Extensible) (WDM)” should be allowing you to get audio output. Could you provide logs so I can take a look?

Hi,
I noticed the same problem.
When I connect with my PC and HTC Vive pro 2, I hear sound.
And when I use the Oculus Quest 2 instead, there is no sound comming from cloudXR.
So it seems that the playback configuration of the server cannot be the issue.

edit:
After connecting once with the HTC Vive, I also got sound on my Quest 2.

Regards
Vasco