No login screen on Ubuntu 22.04 after update

Hello everyone, yesterday I ran update on Ubuntu 22.04 and after running reboot laptop was stuck and failed to load picture on internal monitor but showed output on external one.

I tried reinstalling nvidia driver but that didn’t help. Could you help?

nvidia-bug-report.log.gz (185.4 KB)

All contained logs are from boots to recovery mode. Please do a normal boot and create a new nvidia-bug-report.log.

Here’s latest bug report from normal boot.
Thanks in advance for your help. :)

nvidia-bug-report.log.gz (197.9 KB)

Please remove nomodeset kernel parameter.

Removed from /etc/default/grub file;

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
#GRUB_CMDLINE_LINUX_DEFAULT="quiet splash dis_ucode_ldr nomodeset"
GRUB_CMDLINE_LINUX_DEFAULT=""
GRUB_CMDLINE_LINUX=""

During restart reports A stop job is running to make remote cups printers available locally and retries several times before actually restarting. This is probably separate issue.

Linux is booting normally but it won’t load GPU.
Aditional drivers list is empty.
New report attached.

nvidia-bug-report.log.gz (197.8 KB)

The nomodeset parameter is still set, did you forget to run sudo update-grub?
Furthermore, you shouldn’t comment out the whole line, just remove nomodeset.

Yes, forgot to run update.

Now it won’t boot into login screen.

Please reboot to recovery and create a log from the previos boot
sudo journalctl -b-1 >journal-txt

Here’s output.

journal-txt.txt (538.4 KB)

The amdgpu driver which is driving the internal display is failing and then crashing completely.

Jun 13 10:50:01 asus kernel: amdgpu: HMM registered 128MB device memory
Jun 13 10:50:01 asus kernel: amdgpu: Topology: Add APU node [0x15d8:0x1002]
Jun 13 10:50:01 asus kernel: kfd kfd: amdgpu: added device 1002:15d8
Jun 13 10:50:01 asus kernel: kfd kfd: amdgpu: Failed to resume IOMMU for device 1002:15d8
Jun 13 10:50:01 asus kernel: amdgpu 0000:05:00.0: amdgpu: amdgpu_device_ip_init failed
Jun 13 10:50:01 asus kernel: amdgpu 0000:05:00.0: amdgpu: Fatal error during GPU init
Jun 13 10:50:01 asus kernel: amdgpu 0000:05:00.0: amdgpu: amdgpu: finishing device.

Please try upgrading the kernel to 6.5 by switching to the hwe kernel:
sudo apt install --install-recommends linux-generic-hwe-22.04

Ubuntu logins now but my 2nd HDMI connected display isn’t visible.
I have settings described here hdmi output doesnt work in ubuntu 18.04 - #5 by generix but still it won’t register 2nd display.

nvidia-bug-report.log.gz (210.6 KB)

The amdgpu driver is working now but the nvidia gpu is removed from the bus. Please post the output of
prime-select query
and
grep -i 10de /usr/lib/udev/rules.d/*

Also, please revert the settings you made, those were really only for 18.04.

1 Like

Reverted changes from thread mentioned above.

zlatan@asus:~$ prime-select query
nvidia
zlatan@asus:~$ grep -i 10de /usr/lib/udev/rules.d/*
/usr/lib/udev/rules.d/50-remove-nvidia.rules:ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x0c0330", ATTR{power/control}="auto", ATTR{remove}="1"
/usr/lib/udev/rules.d/50-remove-nvidia.rules:ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x0c8000", ATTR{power/control}="auto", ATTR{remove}="1"
/usr/lib/udev/rules.d/50-remove-nvidia.rules:ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x040300", ATTR{power/control}="auto", ATTR{remove}="1"
/usr/lib/udev/rules.d/50-remove-nvidia.rules:ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x03[0-9]*", ATTR{power/control}="auto", ATTR{remove}="1"
/usr/lib/udev/rules.d/71-nvidia.rules:SUBSYSTEM=="pci", ATTRS{vendor}=="0x10de", DRIVERS=="nvidia", TAG+="seat", TAG+="master-of-seat"
/usr/lib/udev/rules.d/71-nvidia.rules:ACTION=="bind", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x03[0-9]*", TEST=="power/control", ATTR{power/control}="auto"
/usr/lib/udev/rules.d/71-nvidia.rules:ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x040300", TEST=="power/control", ATTR{power/control}="auto"
/usr/lib/udev/rules.d/71-nvidia.rules:ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x0c0330", TEST=="power/control", ATTR{power/control}="auto"
/usr/lib/udev/rules.d/71-nvidia.rules:ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x0c8000", TEST=="power/control", ATTR{power/control}="auto"

The offending file is obviously /usr/lib/udev/rules.d/50-remove-nvidia.rules
Please check which package it belongs to dpkg -S /usr/lib/udev/rules.d/50-remove-nvidia.rules
then delete it and run sudo update-initramfs -u and reboot.

Had no connection to any package.
Removed it and it works perfectly fine now!

Thanks for all your help.
Best of luck and cheers.