Blank login screen ( blank purple screen ) on reboot after Nvidia / Linux ( Ubuntu 20.04 ) updates

I have an Ubuntu 20.04.4 box with a GTX1060. I ran my normal system updates yesterday and after rebooting I am getting a blank purple screen with no ability to login. Based on advice from other threads, I completely uninstalled all of my Nvidia drivers and applications which allowed me to access the GUI but with only 640*480 resolution.

At the advice of Nvidia chat support, I installed the latest 510 drivers, but again after a reboot, I am faced with the blank purple screen with no option to login.

Since I only have access to the terminal on that machine and am using my laptop to post comments, it will be difficult for me to post the output of any configs, but I will do my best to answer any questions.

Please run as root and attach the resulting nvidia-bug-report.log.gz file to your post.
If you have internet connection, you can use pastebinit to upload it from console.

  • install pastebinit (sudo apt install pastebinit)
  • unzip logfile (gunzip nvidia-bug-report.log.gz)
  • upload logfile (pastebinit -i nvidia-bug-report.log)
  • note down and post the url you’re given

I uninstalled the Nvidia drivers for the time being to try to troubleshoot this further. Are there any logs, settings or configurations you want to see from the pc before I reinstall the drivers again?

Is there a preferred method to install the drivers? I have used the .run file and done ubuntu-drivers autoinstall and both have resulted in the same behavior (as soon as I reboot the login screen disappears)

Any recommendation/preference on which driver to install? When the issue originally occurred, I was on the 470 driver, but have also tried installing 510 with the same result.

Just use Software&Updates to install the driver.

I actually can’t… Under additional drivers, ‘Continue using a manually installed driver’ is selected and all other options are greyed out…

Do you have secure boot enabled?

Yes. I have an ASUS Maximus Hero board, and I don’t see a way to disable secure boot, but there is an option for Microsoft Secure Boot, or Other OS, and I have it set to ‘Other OS’.

I reinstalled 510 using nvidia-drivers autoupdate rebooted and got back to the blank login screen with no ability to login to the GUI. Opened a terminal and collected the bug report. It is at Ubuntu Pastebin

The nvidia driver loads fine, the Xserver is starting as well, using your three monitors. So if you don’t see the login, I guess your DM is broken. Do you use standard Ubuntu/gnome?
Please provide a journal output from bootup
sudo journalctl -b0 >journal.txt

DM meaning display manager? Yes Standard Ubuntu 20.04.4.

Journal is at

Everything seems fine. Maybe GDM is just using a broken monitor config, please check
for a file monitors.xml and delete it, then reboot. You could also try to boot with just one monitor connected.

I do not have a monitors.xml file in that location…

Odd, does booting with just one monitor connected bring you to the login?

I have monitors.xml and a backup monitors.xml~ in my ~/.config folder.

That should be there. You can also copy it from ~/.config to /var/lib/gdm3/.config

well booting with one monitor does work perfectly…

So we are getting somewhere :D

So that file has a mixture of old and new configurations in it. I guess it can’t hurt to move it over and try rebooting with all 3 monitors connected and see what happens.

OK so the final solution was to reboot with only one monitor connected. Once I was able to login normally I removed the monitors.xml file from the ~/.config folder.

Reconnected my two monitors, and configured them through display settings normally which created a new monitors.xml in the ~/.config folder which I then copied to /var/lib/gdm3/.config folder.

I was then able to reboot and everything is working perfectly! Thanks @generix for all of your help!!!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.