Setting up eGPU with external monitor on Ubuntu 20.04

Hi!

I’ve been trying to connect my eGPU to my laptop, but for the last three times that I have installed Ubuntu, my laptop’s screen goes blank after rebooting the laptop after installing nvidia drivers onto my laptop. I’m able to visualize the graphics card in my eGPU, but after starting up my computer the next day I am met with a blank screen. The window is on but nothing is displayed…

I’m currently running on Ubuntu 20.04 on a Razer Blade Stealth (early 2019) running on an internal GPU (MX150).

  • eGPU is Razer Core X Chroma
  • GPU Asus ROG Strix 2080ti
  • monitor connected to eGPU is LG27GL850-B

I’m not using a dual boot, my system is running purely on Ubuntu at the moment! Please bear with me I have only started using linux last week!

So actually I have tried several ways to install nvidia drivers and cuda toolkit for my laptop, but no matter how it is installed the PC goes blank after rebooting. Previously I had done the installation with a non-official Nvidia method, but later on I had followed guidelines directly from Nvidia, but the methods all led to the same results… At the moment I’m on a fresh install of Ubuntu 20.04 and haven’t done any installs to the laptop other than updates that were popping up from the Software Updater. I just wanted to ask, which is the method which is recommended when I want to enable my eGPU and enable using the monitor directly from the eGPU?

After setting up the connection to the eGPU, I would like to ask how I should handle my laptop when I am disconnecting my PC from the eGPU when I’m on the go. I have found a package which can be installed (https://github.com/hertg/egpu-switcher), but is there maybe an alternative to this method which is directly provided by Nvidia?

I want to later install Anaconda, ROS and Visual Studio Code, is there something extra that I would need to consider when setting up Nvidia drivers for these applications?

Thank you in advance!!

Just replying to my own post. I gave it a shot to get the connection to the eGPU up and running, but in the end I had to freshly install Ubuntu 20.04 because I couldn’t find a way to revert back to the original settings. Below I have shortly explained what I tried:

  1. Download the recommended Nvidia driver directly from Software & Updates in Additional Drivers (nvidia-driver-450).
  2. Restarted my laptop at this point I was able to see the internal GPU (MX150) when running nvidia-smi in the terminal.
  3. I connected my laptop to the eGPU via thunderbolt connection, made sure that the device was given direct access, for the Razer Core X Chroma there are 2 modules which I need to give access to.
  4. After running nvidia-smi on the terminal, I wasn’t able to see the the external GPU.
  5. I read somewhere that if I update the xorg.conf file to “AllowExternalGpus” = True (or “TRUE” can’t remember at the moment) then it would allow the eGPU to be recognized.
  6. Restarted my laptop and ran nvidia-smi on the terminal and saw 2 GPUs (MX150 and RTX 2080 ti). At this moment the monitor that’s connected to the eGPU only displayed something when the laptop was starting up.
  7. I saw that my monitor was recognized in Nvidia X Server Settings, but when I tried to enable a second display, first of all I was not able to store this new configuration or apply the changed settings. When quitting the application, there was a warning that there were a few things that were not saved yet. It was to update the new configuration, but since it was not possible to update I decided to quit the application anyways.
  8. After restarting the laptop, both the laptop’s display and monitor where black. The laptop’s display was lit, but remained black the whole time. This is the 3rd time that this has happened to me since I tried to connect my eGPU+monitor setup. So I just installed ubuntu again and decided to only repeat step 1 and just wait for feedback from this forum!