No virtual audio devices on AWS cloudXR

I’m building a CXR client app for Oculus Quest 2. I tried having the server and client in the same WiFi network, and the audio input/output worked as expect. However, if I connect the client to the server on an AWS EC2 instance, the audio doesn’t work. It seems no audio devices are found. The EC2 instance was created with Nvidia’s AMI [NVIDIA CloudXR AMI Introductory Offer - WinServer 2019] in AWS Marketplace.
I observed that on my local machine CloudXR server creates virtual audio input and output devices when the client is connected, as listed under Audio Inputs and Outputs in Windows Device Manager.
localVirtualAudioDevices

On the EC2 instance, with the client connected, these virtual devices are not created, as shown in this screen capture.

I wonder how would you guys solve this problem or did I miss anything?

Thanks

I assumed that you know how to enable 2 ways audio in setting files of cloudxr., then issue should be solved like this:

Hi huong, thanks for your reply!
I saw your post, but I’m new to AWS and not sure if I can find the microphone privacy option you mentioned. Could you show me where it is?
I have allowed access to microphone in Windows settings, but it still doesn’t work.

Did you setup correctly audio?
https://docs.nvidia.com/cloudxr-sdk/prog_guide/misc_features.html#audio-support

I did not use DCV, but you may try to find similar setting for audio capture of RDP.

1 Like

Yes, the setup is correct, as audio input and output work correctly for the connection to my local server, and my local and aws server have the same setup.

I’m not sure if my issue is related to DCV/RDP. My question is why Nvidia Virtual Audio Device (WDM) is not added on my EC2 instance. I believe they should be added as in the first image in my original post.

Thanks for your suggestions, huong.
Interestingly, my EC2 instance really is affected by RDP and DCV. Now I avoid using remote desktop, and the virtual devices show up as expected.

Yes, note we call out explicitly in multiple places to NOT use RDP for connecting to remote server during cloudxr runs. The primary issue has been video capture, but as you’ve seen it can affect audio capture as well. We typically recommend using VNC, you might try that if you do need an interactive remote desktop on the instance while running your client.

1 Like