Not able to install jetpack on jetson xavier nx module

Description

I am facing issue to install jetpack 4.3 manually on nvidia jetson xavier nx module.

Relevant Files

I have flashJetson module with bootloader and file system only, excluding other JetPack components with help of below two links.

(Tegra Linux Driver)

https://developer.ridgerun.com/wiki/index.php/Jetson_Xavier_NX/Development/Building_the_Kernel_from_Source

Steps To Reproduce

I have build and flash the image successfully but now want to add jetpack in to the board manually.

I done below some experiments to install jetpack but not get succeed.
1.

sudo apt update
sudo apt install nvidia-jetpack

I have also tried to install jetpack using debian method but not get succeed.

Please let me know proper method to install jetpack manually without using SDK manager.

Hi,

This looks like a Jetson issue. Please refer to the below samples in case useful.

For any further assistance, we will move this post to to Jetson related forum.

Thanks!

This is not useful. I need to install jetpack without using SDKmanager.

Moving this post to Jetson Xavier NX forum to get better help.

Thank you.

You can just use sdkmanager, select the SDK only but not flash the OS.

I have tried that also but getting failed.

Also i want to add packages with the kernel image so is it possible to add packages with rootfs?

I think the better way is you share what “error log” you got but not just telling “it getting failed”.

Also, I am not sure if you understand what yourself is talking about. Because updating kernel image just requires to replace the file /boot/Image. There is no special trick.

Hi @WayneWWW ,

I have flashJetson module with bootloader and file system only. I haven’t installed the jetpack.

Now i want to install jetpack without using sdkmanager. so is there any way to install without using sdkmanager?

We have a customized board which have emmc boot only. I have tried to install jetpack using sdkmanager but i am getting error.

Please find attached log file for more details.
Error.txt (9.7 KB)