Not enough memory to install DeepStream on custom Xavier nx

I have a custom Xavier NX with 16gb emmc memory and an external hdd with 2tb free space. OS is installed in emmc and there is not much space left to install DeepStream. I need to install DeepStream to run my app in jetson. What are the options available for me to use this device to run my app now?

1 Like

Thank PhongNT’s quick suggestion. Please also refer to
Jetson/L4T/Boot From External Device -

Suggest move rootfs to external storage to have enough freespace.

I have tried to follow the instructions given in the link but I am having trouble understanding it properly. I downloaded the files in the external ssd(we are not using the nvme slot, we are using ssd via sata) as there was not enough space in the emmc to even download those. Then I ran the commands from the external drive and followed the steps from the jetson but I could not finish it without error. So maybe I misunderstood it someway but following the commands are a little difficult as it is not very descriptive.

We did not put the jetson in recovery mode and we ran the commands from the jetson to execute the commands and it did not finish without error. We then connected the jetson with ubuntu pc and tried to run the commands from the pc but we could not see the drives connected to jetson so we could not proceed with this approach.

can you tell us what are we actually doing wrong?

Please download the system image through SDKManager. And then go to


You should be able to execute the command like:

$ sudo ./ jetson-xavier-nx-devkit-emmc nvme0n1p1

nvme0n1p1 is the name of ssd via nvme. Yours is ssd via sata and the name may be different.

Hi @DaneLLL ,
I’m having a similar issue except I cannot use suggested solution and flash entire image (tied to provider’s custom image), but only the Deepstream (version 5.0).
Is there a way to install that additional component on other location than the 16GB emmc e.g. my mounted sata ssd drive?