Nsight 5.4 "break mode" instead of properly hitting breakpoints

I’ve recently upgraded my PC and installed a new copy of windows 10 along with VS community 2017. Since then, every cuda project I’ve tried to debug with the nsight cuda debugger no longer stops at breakpoints but instead pulls up a new screen saying that VS has entered “break mode” and the program will crash upon continuing. CUDA programs run as they should outside of that, problems only happen when breakpoints are hit. My drivers are up to date (388.0) and so is Visual Studio. The only times I’ve seen the break mode occur is when the debugger can’t find the linked symbols for the file, but I’ve triple checked and I am compiling in debug x64 mode with the -G flag in the correct build configuration.

Processor: AMD Ryzen x64
GTX 680

Let me know if other specs are needed, and I appreciate the help.

Fixed the problem. I ran visual studio 2017 as administrator and it started working. After that first time, it worked fine with or without being run in administrator mode.

Most likely there was some leftover installation work queued up that didn’t have permission to be completed.