NVCC gives no output when trying to compile

I have a project that uses cuda to perform matrix vector operations this project has been working fine but since I updated visual studio 2022 to 17.9.6 (I Don’t know what version I updated from) my build fails and msvc gives the output the command “(long command)” exited with code 2. I have read other threads and tried changing the verbosity of msvc and nvcc but it gives no errors before this command is run and seems like there is no output. I tried running the command on my own from command prompt but it just gives no output, no exit code, no error, just nothing though there is a small delay as if its doing something when the command is run. I can run nvcc --version and have tried reinstalling cuda.

I have tried to compile the project in the command prompt and in visual studio with no success. I downloaded a sample project and it has the same issue.

I had to empty out my path till it was just system32 and windowsapps. I tried removing the cuda path and the cl path but that did not work for me only worked after removing everything. I restarted after each path I removed.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.