NVIDIA AI Denosier works with Nvidia Quadro k5000?

Hello,
not sure if this is the right place to ask this, but we have a bunch of computers with Nvidia Quadro k5000 and we work with 3dsmax and vray.

while GPU rendering is working fine with CUDA, when we try to use the Nvidia AI denoiser in vray we get an error, saying CUDA not compatible, needed optix 5

Is there anywhere a list of wich Nvidia Cards are compatible with the AI denoiser? is there any driver that actually installs this optix 5 and works with the Nvidia Quadro k5000?

thank you

Hi @reigmanel, welcome!

You can find the list of hardware and software version requirements for OptiX in the OptiX release notes that are published with each release. They can be found here: https://developer.nvidia.com/designworks/optix/downloads/legacy

It depends on which versions of 3dsmax and V-ray you’re using, and I don’t remember how previous versions were set up with OptiX 5. I assume if it’s saying you need OptiX 5 that you’re not using the latest versions of those applications? Unlike the current OptiX versions, OptiX 5 was not delivered as part of the Nvidia graphics driver, it was a separate standalone library. OptiX 5 does run on Kepler hardware, such as the Quadro K5000. Applications like 3dsmax and Vray that were based on OptiX 5 would have integrated the OptiX library into the application directly. You could try to install OptiX 5 from the link above, and see if that helps, in case the application is looking for the OptiX SDK.

It’s hard to say what might be wrong without more information, but I’d speculate maybe your applications or driver version or CUDA version could be too recent for OptiX 5, and that you’re experiencing a version mismatch somewhere. The last release of OptiX 5.1.1 was on CUDA 9.0 with a 390/395 driver. You could try using the older driver, which is likely to require using an older matching version of V-ray.

I hope that helps. I guess getting support for either application will be slow right now, but the best place to find the version and hardware/library setup requirements for 3dsmax and Vray would be on the forums or via direct support from the companies that make those applications.


David.

Thank you David for your answer.

We are using 3ds max 2016 (18,0 SP5 commercial) and Vray-next (update 3.1 (4.30.01 build 00001)
Our operative system is Windows 10 Pro 64bit verison 20H2
As CPU we have Intel® Xeon® CPU E5-2680 0 @ 2.70GHz 2.70 GHz (2 Prozessoren)
And as GPU NVIDIA QUADRO k5000 with driver version 27.21.14.5239

the message that we get from V-ray when rendering in CPU or GPU and using the AI denoiser is:
[VUtils::setDenoisingDeviceContext] No suitable CUDA devices available for denoising. Compute capability >=5.0 is required.

Now that I read the message again I realise it says nothing about optix…sorry for the confusion, I am not sure where did I read that.

When we render with the vray next GPU, we got engine type set to CUDA and under the “Device name” got checked this: *Nvidia CUDA Quadro k5000 GPU index0
Under that it appears the next message when the first render is done: “Succesfully updated the user and the current process env variable VRAY_GPU_PLATFORMS=nvidia cuda quadro k50000 gpu index0; with the device to use”

Also, when starting a render in the vray messages, it says: “Optimized CUDA kernel assembled succesfully”
But when the AI denoiser kicks in, we get the error message from above saying that no CUDA devices are available for denoising.

Any ideas?
thank you!

No suitable CUDA devices available for denoising. Compute capability >=5.0 is required.

Compute capability => 5.0 means Maxwell GPUs and newer. That error message simply says that your Kepler based GPU, which is compute capability 3.x and already five GPU generations old, is not supported by the application’s OptiX based renderer or AI denoiser path (because it’s built against a recent OptiX SDK with support for the hardware ray tracing features on RTX boards, and those SDKs versions don’t support Kepler GPUs anymore).

Please see this knowledge base article for the minimal V-Ray system requirements:
https://docs.chaosgroup.com/display/KB/Hardware+Recommendations
and esp. this link in there to the 3dsmax support:
https://docs.chaosgroup.com/display/VMAX/System+Requirements
which says the same in the last line.

(Also there is no need to install an OptiX SDK for running any commercial application which is using OptiX.
The OptiX SDK is only required during application development.
The application itself needs to ship the required libraries and the target system needs to have a display driver version installed which the application requires.)