Problems with CUDA

Hello everyone. I downloaded Optix 3.5 and tested the precompiled examples and they all worked fine. I, then, downloaded CUDA 6.0 and after that I am gettin an unknown error. I tried to install CUDA 5.0 but now I get an Optix error A supported NVidia GPU could not be found.
What should I do now?

First, OptiX 3.5.1 is not supporting CUDA 6.0.
Please always read the OptiX Release Notes before configuring the development system.

You can have multiple CUDA Toolkit versions installed side by side, but you need to set the CUDA environment variables to the one you actually want to use.

OS is Windows?
Do a “set C” on the command prompt to see which environment variables are set.
These must point to the correct installation and lib bitness: CUDA_PATH, CUDA_INC_PATH, CUDA_LIB_PATH

If anything is still set to CUDA 6.0, change it to your CUDA 5.0 paths.
Or check your e-mail for announcements to registered OptiX developers for another solution!

All, please include at least the following information when reporting issues:
OS version, OS bitness, installed GPU(s), diplay driver version, OptiX version, CUDA Toolkit version, compiler version.
That helps to reduce turnaround times.

Thank you for the answer. This is the output of set C

CUDA_PATH=C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v5.0\
CUDA_PATH_V5_0=C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v5.0\
CUDA_PATH_V6_0=C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v6.0

The ony reference to cuda 6 is that path, should I get rid of it? Also, some other applications are not working anymore, should I reinstall the drivers aswell? I have a gt540M

The CUDA_PATH and esp. CUDA_INC_PATH and CUDA_LIB_PATH are what count. The others are just helpers and can remain.

Ok, so a mobile system.
Did you install the drivers coming with the CUDA Toolkit 6.0?

There is no need to do that if the Toolkit is not brandnew.
Once newer officially released drivers are available supporting that CUDA version you can use these instead. Look here http://www.nvidia.com/Download/index.aspx?lang=en-us

I always select the “custom install” and check the “clean install” option.