Nvidia control panel not working after installing CUDA Toolkit

I am new to CUDA Development. I installed CUDA Toolkit 8.0 on my laptop running windows 10 home and has GTX 960M. Before Installing CUDA Toolkit, the context menu on desktop (right-click on desktop) used to have an option to access Nvidia Control Panel. And there also used to be system tray icons for accessing GeForce experience and GPU Activity status icon.
But after Installing CUDA Toolkit, these icons and options are no longer visible. And when I try to launch the Nvidia control panel from the System control panel, an error dialog box appears stating - “Nvidia Display Settings are not available. You are not currently using a display attached to Nvidia GPU.”
I don’t understand what this means. Did mess-up the CUDA Toolkit Installation? Do I have to re-install the Display Drivers?

Note: During the installation, I deselected the Display Driver, GeForce Experience and PhysX from the options because I already had the latest up-to-date versions of the respective tools installed on the system.

Please help, I don’t know what to do…!!!

I currently have the same issue.

Laptop using the 1050 using the 378.49 driver, the context menu option for the Nvidia control panel disappeared, and manually running the file triggered the same error as mentioned above.

Issue appeared after installing the CUDA 8 toolkit while deselecting the driver and Physx option.

Here is the current dxdiag output:

Card name: NVIDIA GeForce GTX 1050
       Manufacturer: NVIDIA
          Chip type: GeForce GTX 1050
           DAC type: Integrated RAMDAC
        Device Type: Render-Only Device
         Device Key: Enum\PCI\VEN_10DE&DEV_1C8D&SUBSYS_07BE1028&REV_A1
      Device Status: 0180200A [DN_DRIVER_LOADED|DN_STARTED|DN_DISABLEABLE|DN_NT_ENUMERATOR|DN_NT_DRIVER] 
Device Problem Code: No Problem
Driver Problem Code: Unknown
     Display Memory: 12171 MB
   Dedicated Memory: 4053 MB
      Shared Memory: 8118 MB
       Current Mode: Unknown
        Driver Name: C:\Windows\System32\DriverStore\FileRepository\nvdmi.inf_amd64_fd06216336fcf4a2\nvd3dumx.dll,C:\Windows\System32\DriverStore\FileRepository\nvdmi.inf_amd64_fd06216336fcf4a2\nvwgf2umx.dll,C:\Windows\System32\DriverStore\FileRepository\nvdmi.inf_amd64_fd06216336fcf4a2\nvwgf2umx.dll,C:\Windows\System32\DriverStore\FileRepository\nvdmi.inf_amd64_fd06216336fcf4a2\nvwgf2umx.dll
Driver File Version: 21.21.0013.7849 (English)
     Driver Version: 21.21.13.7849
        DDI Version: 12
     Feature Levels: 12_1,12_0,11_1,11_0,10_1,10_0,9_3,9_2,9_1
       Driver Model: WDDM 2.1
Graphics Preemption: Pixel
 Compute Preemption: Dispatch
           Miracast: Not Supported by Graphics driver
Hybrid Graphics GPU: Discrete
     Power P-states: Not Supported
  Driver Attributes: Final Retail
   Driver Date/Size: 1/19/2017 7:00:00 PM, 16875464 bytes
        WHQL Logo'd: Yes
    WHQL Date Stamp: Unknown
  Device Identifier: Unknown
          Vendor ID: 0x10DE
          Device ID: 0x1C8D
          SubSys ID: 0x07BE1028
        Revision ID: 0x00A1
 Driver Strong Name: oem26.inf:0f066de312316fb4:Section341:21.21.13.7849:pci\ven_10de&dev_1c8d&subsys_07be1028
     Rank Of Driver: 00D10001
        Video Accel: Unknown
        DXVA2 Modes: DXVA2_ModeMPEG2_VLD  DXVA2_ModeVC1_D2010  DXVA2_ModeVC1_VLD  DXVA2_ModeH264_VLD_Stereo_Progressive_NoFGT  DXVA2_ModeH264_VLD_Stereo_NoFGT  DXVA2_ModeH264_VLD_NoFGT  DXVA2_ModeHEVC_VLD_Main  DXVA2_ModeHEVC_VLD_Main10  DXVA2_ModeMPEG4pt2_VLD_Simple  DXVA2_ModeMPEG4pt2_VLD_AdvSimple_NoGMC  
      Deinterlace Caps: n/a
       D3D9 Overlay: Unknown
            DXVA-HD: Unknown
       DDraw Status: Enabled
         D3D Status: Enabled
         AGP Status: Enabled
           MPO Caps: Not Supported
        MPO Stretch: Not Supported
    MPO Media Hints: Not Supported
        MPO Formats: Not Supported

CUDA still works fine, and tensorflow on Win 10, Python 35 has the following output:

I c:\tf_jenkins\home\workspace\release-win\device\gpu\os\windows\tensorflow\stream_executor\dso_loader.cc:128] successfully opened CUDA library cublas64_80.dll locally
I c:\tf_jenkins\home\workspace\release-win\device\gpu\os\windows\tensorflow\stream_executor\dso_loader.cc:128] successfully opened CUDA library cudnn64_5.dll locally
I c:\tf_jenkins\home\workspace\release-win\device\gpu\os\windows\tensorflow\stream_executor\dso_loader.cc:128] successfully opened CUDA library cufft64_80.dll locally
I c:\tf_jenkins\home\workspace\release-win\device\gpu\os\windows\tensorflow\stream_executor\dso_loader.cc:128] successfully opened CUDA library nvcuda.dll locally
I c:\tf_jenkins\home\workspace\release-win\device\gpu\os\windows\tensorflow\stream_executor\dso_loader.cc:128] successfully opened CUDA library curand64_80.dll locally
I c:\tf_jenkins\home\workspace\release-win\device\gpu\os\windows\tensorflow\core\common_runtime\gpu\gpu_device.cc:885] Found device 0 with properties: 
name: GeForce GTX 1050
major: 6 minor: 1 memoryClockRate (GHz) 1.493
pciBusID 0000:01:00.0

I posted the same question on StackOverflow, and got this solution: http://stackoverflow.com/questions/41658308/nvidia-control-panel-not-working-after-installing-cuda-toolkit-8-0. This worked for me. I did the following.

  • Uninstall CUDA and the Nvidia Display Drivers (if needed use DDU).
  • Install CUDA with all the components (custom installation --> CUDA+PhysX+Graphics Driver+GeForce Experience)
  • After CUDA installation restarts the computer.
  • Then install the latest Display Drivers (custom installation --> Graphics Driver+GeForce Experience+PhysX)
  • Immediately after installation, Restart the system.
    Now Everything should work fine (CUDA + Control Panel)

There are many users who have complained that their Control Panel is not opening. This error has reach over many Windows versions including 7 to 10. People who try to open the NVIDIA Control Panel through Start menu doesn’t work. Also by examining Windows Update explains that your drivers are outdated but actually they are not old. Here we have some solutions to fix this issue but in case you want to go for detailed solution then you can visit this website https://appuals.com/fix-nvidia-control-panel-wont-open/.

Method 1- Turning off Quick Boot: You can fix it by entering your system’s BIOS settings and turn off Quick Startup or Quick Boot. You can also gain access to the BIOS while utilizing any of the keys: Esc, Delete or F2 to F8, F10 or F12.

Method 2- Update .NET Framework and VC++ Redistributable: NVIDIA apps start on .NET Framework and VC++ Redistributable. Otherwise, you can also run a Windows update by tapping the Start button, write Windows Updates, click Enter and tap the option of Search for Updates.

Method 3- NVIDIA Display Driver Service: Tap the Windows + R keys to start the run prompt. Then write services.msc and click Enter so you could open the Services console. Find the option of NVIDIA Display Driver Service and double-click. Manage the Startup type into the Automatic and boot the service in case it’s not working. Do it exactly the same for other NVIDIA-related services. Try to start the NVIDIA control panel and confirm in case the error has fixed or not.