Nvidia driver fails to load at random times - Occurs on system boot, a simple restart fixes it

Hi , since couple of weeks i’m using 5.9 kernel series with 455.45.01 driver which offers kernel 5.9 support. However at completely random times ( sometimes it goes without issues at consecutive system boots ) but usually at every 2 of system boots it fails to load itself. A simple restart to system fixes it.

I gathered dmesg outputs and nvidia bug reports from both situations ( failed to load vs succesfully loaded)

dmesg-doesn’t load.txt (78.3 KB) dmesg-succesful load.txt (78.7 KB) nvidia-bug-report.-loaded successfully.log.gz (291.9 KB) nvidia-bug-report-failed to load.log.gz (253.9 KB)

Brief system info from inxi -SMGxx: (Secure boot is disabled on my system)

  Host: asus-FX553VD Kernel: 5.9.13-xanmod2 x86_64 bits: 64 compiler: N/A 
  Desktop: Cinnamon 4.6.7 wm: muffin dm: GDM3, LightDM 
  Distro: Linux Mint 20 Ulyana base: Ubuntu 20.04 focal 
  Type: Laptop System: ASUSTeK product: GL553VD v: 1.0 
  serial: <superuser/root required> 
  Mobo: ASUSTeK model: GL553VD v: 1.0 serial: <superuser/root required> 
  UEFI: American Megatrends v: GL553VD.308 date: 04/29/2019 
  Device-1: Intel HD Graphics 630 vendor: ASUSTeK driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:591b 
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: ASUSTeK 
  driver: nvidia v: 455.45.01 bus ID: 01:00.0 chip ID: 10de:1c8d 
  Display: x11 server: X.Org 1.20.8 driver: modesetting,nvidia 
  unloaded: fbdev,nouveau,vesa tty: N/A 
  OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2) 
  v: 4.6 Mesa 20.3.0 - kisak-mesa PPA direct render: Yes

The driver loads in both cases, just a little bit late. It seems, the driver has not been properly embedded in the initrd. Already tried to rebuild it?
sudo update-initramfs -u

While i’m sure that is not the issue i tried it anyway , no luck. Still randomly fails to load driver at boot , sometimes goes without an issue like 5 days then fails at two days in a row.