Nvidia drivers don't include access to TTY terminal?

Folks:

Posted this thread on the main Nvidia community forum and @jaafaman suggested I post over here for this kind of problem. I read the pinned post about running the nvidia-bug-report.sh, which I did after I tried to keystroke into a TTY and I scrolled through it, couldn’t understand it, but I don’t see a place to attach it to this post as there is on some forums??? It’s set up as a .gz file, but opening it is quite large, so I won’t paste it here at this time. Right now I’m in Leap 15.1–fn+Ctrl+alt+f2 goes to black screen and fn+ctrl+alt+f7 gets it back to GUI, but no TTY.

Awhile back I upgraded my '12 Mac Pro video card to a GTX 780 so that the machine could run 10.14 Mojave. I run a multi-boot machine with a number of OSX versions and a number of linux installs of various flavors. After that upgrade I started noticing that I couldn’t “revive” from suspend and posted my concerns on a debian based forum and they recommended switching from the “nouveau” drivers to proprietary nvidia drivers. On the two ubuntu based systems I have installed that is very easy through the GUI, but on the OpenSUSE and debian systems it takes some knowledge . . . but I got that done starting a few months back.

Recently I was trying to help a buddy get a linux install on his Mac and I was reading a thread on the Ubuntu Apple Hardware User sub-forum and I thought, “Hey, why don’t they log into a TTY to help solve their problem?” . . . so just to check it, I tried to log into a TTY on my '09 MBP that also has Nvidia graphics card in the Leap 15.1 partition I have on that computer . . . and making the usual keystrokes the screen went black . . . but, no TTY, no login prompt . . . nuttin but black. Possibly in that computer I might have been able to “exit” the black and back into the GUI. But, on some of my MP linux installs the keystrokes get me to black and then the computer shuts down?? Or, in some cases won’t return to the GUI . . . have to shut the computer down . . . and cold boot.

So, I became somewhat alarmed, all of the nvidia drivers were either added by the “additional drivers” or in OpenSUSE by adding Nvidia to the repos via Yast, selected from what was shown to be appropriate for the OS . . . . Meaning I didn’t “find” the drivers lying in a ditch, and then like clean the dirt off of them and then try to “extract” them and install the parts . . . . I posted my dilemma on the Lubuntu Users list serve, and a little while later a guy replied saying, “I booted a daily and checked it out and it’s working fine . . .” and he listed his computers and their hardware . . . took me a few hours to realize, “Hey, they are all radeon cards that he is using . . .”??? And then I thought back to the “suspend” issues after the Nvidia card, and that made me think, “Perhaps this is an Nvidia driver issue?” Ran a google on it, found a thread in the Linux Mint forum describing almost the same problems with the TTY and tracing it to Nvidia drivers, I think this LM thread was from 2016 . . . it gave a few mods to do to the /etc/default/grub file, I tried a couple of them . . . but it didn’t fix the issue. The thread suggests if that didn’t work, wait until Nvidia comes up with an update . . . ???

In my Siduction install I have from xinxi -v3 “driver: nvidia v: 430.40” keystrokes get me to a black screen and then back to GUI, but no TTY terminal shows up . . . kind of handy to be able to get to a TTY at times . . . is there a “fix” coming? Seems to be affecting, my ubuntu, OpenSUSE, debian system in two Macs with Nvidia cards . . . . Any thoughts or easy fixes??
nvidia-bug-report.log.gz (53.9 KB)

The button to attach a file is the paperclip that pops up when you hover the mouse over the upper-right corner of your post.

When switching to the console, the NVIDIA driver tries restores the mode described by the kernel in the screen_info structure, assuming it matches the configuration of a GPU in the system. It’s possible that Macs do something quirky that confuses that detection. Hopefully a bug report log will reveal what is going wrong.

@aplattner:

OK, thanks kindly for the reply . . . when I was on my home desktop for some reason the browser couldn’t “find” this web page . . . . Since I posted here I changed one of my linux installs to see if I could get to a tty . . . and by going to a fresh Tumbleweed/XFCE install, which I have not yet added “Nvidia” drivers to-- I was able to get a working TTY.

Now, I’m booted in my MBPro . . . and I tried to get into a tty . . . screen went black, nothing else . . . was able to get back into the GUI with F7?? I then ran the nvidia-bug report that should be attached here . . .?

Oh, sorry, it didn’t occur to me that this system is using the legacy MCP79 integrated chipset and the 340.* legacy drivers. Console handling is all different in those old drivers and unfortunately we don’t have any plans to go back and fix long-standing issues in legacy drivers at this point.

@aplattner:

OK, that’s “fair” . . . that recently posted report was made on my '09 laptop, which I just happened to be using yesterday, as it was also running Leap 15.1 --the same system as I was running on my '12 desktop . . . but the question is would that also bring the same “we don’t look back” problem–as it is now “old” at seven years??

I since nuked my Leap 15.1 install on my desktop and I went to TW XFCE running “nouveau” and I had no problem getting into a tty and running an upgrade. But, I have possibly 4 other linux installs with the Nvidia proprietary drivers that have problems with getting in and out of a tty shell and I could reboot and try to get the nvidia bug report from them.

Or, I think I have the original bug report I ran on this computer '12 Mac Pro with the GTX 780 card run in Leap 15.1 that I could post . . . question would be whether anything would change as far as getting some “updates” to the drivers such that a TTY shell could happen? Post another nvidia-bug-report from an Nvidia powered linux install, the one I have already from this computer, or, not going to change anything??

@aplattner:

Today I’m running my '12 Mac Pro in the Siduction partition with Nvidia proprietary drivers 5.2+ kernel . . . I tried to get to a TTY using keystroke . . . screen went black, then with F key it returned to the GUI. I ran the bug-report.sh and I’ll post it here.
nvidia-bug-report.log.gz (1.11 MB)

Interesting. It looks like your kernel’s framebuffer configuration is a little unusual (or as I described it in my earlier post, “quirky”):

[    1.281974] simple-framebuffer simple-framebuffer.0: framebuffer at 0x80020000, 0x800000 bytes, mapped to 0x(____ptrval____)
[    1.281976] simple-framebuffer simple-framebuffer.0: format=a8r8g8b8, mode=1280x1024x32, linelength=8192

So apparently your framebuffer console starts at 0x80020000, whereas your GPU’s BAR1 starts at 0x80000000. The driver currently only supports framebuffer consoles where the system maps the console at the very beginning of the BAR1 aperture.

@aplattner:

Alrighty, thanks for taking the time to look at it . . . so that “quirk” is via installer? I haven’t made any modifications, other than changing to the nvidia drivers . . . whereas in the system where I now don’t have the nvidia drivers installed . . . the TTY is operational.

Sounds like you are saying it isn’t “adjustable” to get the nvidia drivers running and have access to TTY mode???

No, I think it’s a quirk of the Mac EFI platform that makes it behave slightly differently to UEFI, in a way that isn’t supported by the nvidia driver.

I filed internal bug number 2709067 to request adding support for this, but I can’t promise anything about if or when it’ll get implemented.

@aplattner:

OK, very good, thanks for that . . . but I won’t hold my breath waiting for the response. It’s a feature that is an important part of linux, and then other functions, like “suspend” weren’t working w/o going to nvidia drivers . . . hard to find the perfect answer . . . to everything. : - )

You mentioned you filed an internal bug number. Does that mean there will not be a public facing page where one can check back periodically to see its status?
I believe this may be the same issue with my 2014 MBP, with the 750M. I’m on the 5.5.10 linux kernel on Arch Linux with the 440.64 nvidia driver.

1 Like