NVIDIA Geforce 1050Ti is not detected after update (Ubuntu 20.04)

Hello,
I have dual VGA cards:

  • Intel HD Graphics 630

  • NVIDIA Geforce 1050Ti mobile.

I was able to install the latest NVIDIA driver (450.66-0ubuntu0.20.04.1) and it was recognized until latest update. It disappeared although the driver is still installed.

sudo apt install nvidia-driver-450

Reading package lists... Done
Building dependency tree       
Reading state information... Done
nvidia-driver-450 is already the newest version (450.66-0ubuntu0.20.04.1).
The following package was automatically installed and is no longer required:
 libfprint-2-tod1
Use 'sudo apt autoremove' to remove it.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

But other commands show only Intel HD card. It works well on Windows so I believe something is blocking it.

I tried
sudo prime-select nvidia

Same problem.

1 Like

I found out a fix.

You should uninstall or purge NVIDIA drivers, then follow the GUI step of installing proprietary driver

What version did you install to fix the issue? I was having the same problem, and after purging all the nvidia packages, the nvidia-dkms-4xx can’t reinstall properly.

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update
sudo apt-get install nvidia-driver-450
sudo reboot

This is what worked with me. However, I believe NVIDIA is not fully compatible yet with 20.04. You may experience some lag in screen when scrolling a browser.

Thanks, it indeed works to reinstall the drivers.
My additional issue was due to using clang as the system default set through update-alternatives, which the installer apparently didn’t like. Found that out by reading the make.log…
Cheers!

1 Like

you can easily do a ( ubuntu-drives autoinstall ) this will be install for you the latest version of driver but if you need method more work you can download drive from nvidia.com/download/ search for your drive download for ubuntu and restart your pc and start it with safe mode go to download folder and install the download Nvidia driver i hope it is clear

I had to use a specific version as I am using CUDA and TensorFlow. Each driver is supported by a specific CUDA version

Hi, my name is Giuseppe and I have a laptop (Lenovo X1 extreme) with the same 1050Ti GPU as you.
I have installed Ubuntu 20.04 but I have some problems selecting internal or nvidia GPU to run specific software and to use an external monitor.
You can help me?
I have tested both the tutorials and the drivers (470-460) and now I have tested your configuration.

Hello Giuseppe ,
The NVIDIA GTX 1050 Ti is now fully compatible with 20.04. You can use the latest driver with no issues. I am sure it is working well as I use it for deep learning training.

Hi, to date the latest version is 470.
but the 495 is now available
which version do you recommend me to use?


after upgrade whit 495

optirun not work
external monitor not work

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

Hi
thanks
nvidia-bug-report.log.gz (123.7 KB)

https://wiki.ubuntu.com/Bumblebee

this is the tutorial I followed to activate the nvidia when needed.

Please uninstall bumblebee and bbswitch, it’s outdated and unneeded on modern notebooks. You can then use nvidia-settings to switch to on-demand mode and start applications by running
__NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia

Hi all.
given the problems with the external monitor and with the drivers, I formatted the laptop.
first try
I format and immediately on reboot I see that the pc had set the open source driver. I execute in the terminal add-repository of the graphic drivers among the list of drivers also the 495 appears. I select the 495 but at the next restart the pc starts without a graphic interface.

second test
format again. at the first restart the external monitor works and the laptop has automatically selected 470 drivers (proprietary, tested). at this point that everything works from the terminal and I run the update && upgrade command and at the new restart the external monitor has disappeared again.
the drivers are always 470 and if I try to open nvidia x server it is empty compared to before it was full of all parameters and options.

Can any of you help me?

peppe@X1:~$ grep nvidia /etc/modprobe.d/* /lib/modprobe.d/*
/etc/modprobe.d/blacklist-framebuffer.conf:blacklist nvidiafb

SOLUTION

I explain to everyone the procedure I followed to solve the problems with the graphics card and the external monitor At the moment the following procedure works, I will update you if there are other problems. I formatted the Lenovo laptop with Geforce 1050 Ti and installed Ubuntu 20.04 LTS After that I ran the following commands

sudo lspci -H 1
sudo apt update && sudo apt upgrade
sudo reboot
sudo lspci -H 1
ubuntu-drivers devices
sudo ubuntu-drivers autoinstall
sudo reboot
xrandr 
sudo lspci-H 1

sudo lspci-H 1 is a command used to display the active graphics card

I tried different procedures but each produced different problems:
external monitor not recognized
only the external monitor worked and not the laptop monitor
inability to choose the graphics card

I hope the guide can help anyone with the same situation as me.
Thanks to everyone and your help

UPDATE

I tried to select only the Intel card
when restarting the external monitor does not work and is not recognized

I selected only the Nvidia card again
when restarting the external monitor works correctly
I had to send the command
sudo service lightdm restart
because around the cursor there was a strange box with the frozen image

I provide as further information for those who can help me to solve the problem of the second monitor only with Intel, which I have installed lightdm

There are likely some blacklist files remaining, please post the output of

grep nvidia /etc/modprobe.d/* /lib/modprobe.d/*