Nvidia GeForce MX250 on Linux openSuSe Leap 15.2 not working

Hello,
I can’t get my GeForce MX250 graphics card to work.
I did a fresh install of openSUSE Leap 15.2 using Virtualbox on my ASUS Windows 10 notebook.
libdrm-nouveau2 installs by default. But as I understand it doesn’t support GeForce MX250.
Only 800x600 is possible on my monitor.

I did the following steps:

  1. Add NVidia to my Yast repository
    https://en.opensuse.org/SDB:NVIDIA_drivers
  2. Via YAST I installed
    • nvidia-computeG05
    • nvidia-gfxG05-kmp-default
    • nvidia-glGO5
    • suse-prime
  3. I ran “sudo command prime-select nvidia”
  4. I rebooted Linux. My KDE no longer works. I reboot into command line.

Now what?

Somewhat of solution. First, my real problem was KDE was stuck at 800x600. I don’t care if I use Intel integrated GPU or Nvidia GPU.
I solved KDE by going to:
KDE > System Settings > Startup and Shutdown > Background Services
and uncheck KScreen2.
Afterwards, KDE would properly resize.
I discovered this on a forum. To quote:
[vbox 6.1.4 works, vbox 6.1.6 is totally broken wrt resizing, and starting with vbox 6.1.8, for some reason, kscreen starts hammering VBoxClient daemon for 800x600 (aka followPreferredMode ). This only affects KDE 5.15 and beyond, which TW has of course.]