Nvidia GEFORE GTX 960M driver fails on Ubuntu 16.04

Basically, I’ve been tortured by your products. I have installed Ubuntu on my Notebook which happened to have Nvidia graphic card GEFORE GTX 960M. After installing Ubuntu, I installed Nvidia driver from Ubuntu’s utility additional drivers. After installing the driver, I had to reboot the system. After rebooting everything works fine as long as I’m using Nvidia graphic card. When I switch to Intel graphic card from nvidia-prime and logout, Ubuntu breaks and I always have to force shutdown the machine. When I turn the machine on again, the same thing happens, before the display manager shows nothing everything freezes and I only see a black screen and **the notebook’s fan rotates so fast and again when this happens I have to force shutdown the machine from the power button. I just don’t know why the fan rotates so fast that I can hear it loudly.

My notebook is ASUS ROG GL-752

I have tried downloading the driver from nvidia.com where I’m quite sure for the millionth time that I’ve chosen the right driver. Neither the official driver from Ubuntu works nor the downloaded driver from nvidia.com does anything useful. Both had the same issue: the display manager doesn’t show up and the fan starts rotating so fast, and I had to force shutdown the machine every time this happens.

This is devastating. What is the solution?

I cannot post nvidia-bug-report.log.gz file because as I said I had to force shutdown the machine every time I encounter this problem. I fix this by going to recovery mode and I remove nividia driver then I add nouveau.modeset=0 to grub.

Try

acpi_osi=! acpi_osi="Windows 2009"

as kernel parameters.
Read
https://bugzilla.kernel.org/show_bug.cgi?id=156341
https://devtalk.nvidia.com/default/topic/1010972/linux/problems-with-opensuse-and-my-asus-rog-gl752vw-dh71/
https://devtalk.nvidia.com/default/topic/1001621/linux/prime-select-nvidia-gt-log-off-doesn-t-work-but-reboot-does-on-375-quadro-m1000m-dell-precision-550/
Report back.

I appreciate your help. I tried your soultion, but grub refuses to update and complains that there’s no Windows 2009. I’ve tried to change

acpi_osi="Windows 2009"

to

acpi_osi="Windows"

but that didn’t help.

I downgraded the kernel to 4.6.0 It seems the driver works better with 4.6.0, but with this kernel when I switch to Nvidia from the nvidia prime and then logout, nothing changes Intel remain in use, even after reboot. I can say the problem of the fan running at full speed doesn’t exist when I used Linux kernel 4.6.0.

I still however face problems:

    • I cannot switch to nvidia, the Intel graphic card remains in use after switching to nvidia from nvidia prime even after reboot.
  1. Fan issue was eliminated by downgrading to Linux kernel 4.6.0.

  2. Screen brightness cannot be controlled either through fn keys or directly from settings. I cannot decrease of increase brightness. I was able to solve this problem by upgrading the Intel driver and then I re-installed the nvidia driver.

Unfortunately, at the end I decided to remove Ubuntu and to make a fresh install after I spent the whole day trying to find a fix.

This makes me wondering, why did the driver work under Linux 4.6.0 but not older versions? I tried older kernel versions, all had the same problem, installing nvidia driver literally breaks the system and when switching to Intel the fan runs at full speed. Of course, it worked under 4.6.0, but it didn’t exactly worked as I mentioned above. I faced many issues as a result I was not able to continue fixing and I decided to make a fresh install :(.

Are there any suggestions?

Read this again:
https://devtalk.nvidia.com/default/topic/1010972/linux/problems-with-opensuse-and-my-asus-rog-gl752vw-dh71/
there’s an example how to insert it into grub.

Thank you so so much. This worked!Now I feel a sense of relief. Thank you!

Fine to hear this. Please enlist on the kernel bug mentioned to keep it alive and growing. You already mentioned it, it’s devastating.

This is the link to the reported kernel bug:

https://bugzilla.kernel.org/show_bug.cgi?id=196037