Nvidia GPU was not recognized after reinstallation

I have a Ubuntu 18.04 system with an Intel integrated and a Quadro T2000 graphics card. I had the Nvidia driver successfully installed. However, since there was some issue when using the docker, I decided to re-install the Nvidia driver.

I uninstalled using sudo apt-get remove -y --purge nvidia-*', then installed the Nvidia driver 440.82 using Software & Updates. After the installation and reboot, nvidia-smigave normal output, butnvidia-settings` gave an error message (see pics below). Besides, in the X server panel, the “Prime Profiles” tab was missing.

Screenshot from 2020-04-14 18-35-31

I then uninstalled and installed the driver again from Software & Updates and rebooted. However, this time both nvidia-smi and nvidia-settings gave error messages. Though prime-select query showed that Nvidia was chosen, glxinfo|egrep "OpenGL vendor | OpenGL renderer" showed that the Intel card was actually used (see pic below)

I’m pretty confused why reinstallation cannot correctly install the driver, and why each reinstallation gives a different wrong result. It seems that the previous Nvidia drivers might not be completely removed, thus causing trouble after the new installation.

Does anyone know what the problem is? Thanks!

The bug report is attached.

You installed three drivers over another, one from Ubuntu repo, one that came bundled with cuda and one from .run installer.
Please try this:

  • Don’t use the .run installers, use --uninstall to uninstall them
  • purge anything nvidia/cuda
  • install the driver from repo (Software&Updates)
  • download the cuda 10.2 .deb
  • add the repo to your system (first 6 steps from install instructions on download page)
  • don’t install cuda
  • instead, run sudo apt install cuda-toolkit-10-2
1 Like

Thank you. I used the --uninstall option to uninstall the driver installed by .run file and the output is

I then run following purge commands

sudo apt-get remove -y --purge cuda-toolkit* 
sudo apt-get remove -y --purge libcuda* 
sudo apt-get remove -y --purge cuda 
sudo apt-get remove -y --purge nvidia-* 
sudo apt-get autoremove –y 
sudo apt-get autoclean 
sudo rm -rf /usr/local/cuda*

I’ve searched the system, and there is no file that has “nvidia” or “cuda” in its file name except in a git folder for my own project.

However, after installing the driver from repo (Software&Updates), the GPU driver does not seem to be correctly installed.

Bug report is here.

Feels like the driver is not cleaned completely. What uninstall/purge command would you recommend in this case? Thanks!

Probably a blacklist file in place. Please try this:

  • make sure nvidia-prime is installed (sudo apt install nvidia-prime)
  • switch to nvidia (sudo prime-select nvidia)
  • remove stray blacklist files (sudo rm /lib/modprobe.d/blacklist-nvidia.conf /etc/modprobe.d/blacklist-nvidia.conf)
  • update the initrd (sudo update-initramfs -u)
  • reboot

Thank you! I have tried your method and there are indeed blacklist-nvidia.conf files. However, after doing all these steps and reinstalling the driver, the driver still does not work normally. So I re-installed Ubuntu and now the driver works.

Help me, how i do this with Fedora 31, i installed the RUN file, but any program recognize the Nvidia Driver 440.82, when i run in terminal, nvidia-settings give the error ERROR: Unable to load any info from any available system


nvidia-settings is an application for graphics settings, so it requires an Xserver running on the nvidia gpu.
Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post. You will have to rename the file ending to something else since the forum software doesn’t accept .gz files (nifty!).