nvidia grid m60

We have an application on Fat-Clients which has either NVIDIA GeForce 9600/ 9800 or Nvidia GeForce 285/ 295 graphic card attached because of OpenGL requirement. We are now to go "Virtual Desktop" with the application.

We have cisco ucs with NVidia grid m60 attached, and ESX as hypervisor.

Unfortunately the application is not working as expected, so I am wondering if m60 do support OpenGL at all.

Thanks for your response

For sure we support OpenGL with GRID. The must be something else going wrong. Could you please give some more details what you did. Hypervisor version/VDI solution/NV driver version…

Sorry that I’m just coming back, was expecting Email notification that didn’t come.

I have to bring in some corrections regarding the graphic cards. We actually have m6 Grid card, and on the Fat-Clients are either Quadro 5000, Quadro FX4800 or Quadro K5000.

Below is the Infrastructure.

HW: cisco UCS B200 M4
Graphic: NVidia M6-0B Grid
Hypervisor: VMWare ESX 6.5
Virtualization: XenDesktop 7.13
VDA-Client: Windows 7 (x64)
NVidia Driver: NVIDIA Graphics Driver 369.71, NVIDIA nView 148.03, NVIDIA WMI 2.27.3

Just got information from Leica that a "Quadro" driver would be required for that function to work on a normal RDP, though we are trying through ica (HDX) protocol

Any direction you could point me to look further.

Thanks

Hi

You still haven’t said what the problem is? … “Not working as expected” doesn’t give us any information to help you. Is it an application performance issue or is it a visualisation issue?

Looking at the details you’ve provided above, you may want to try increasing the vGPU profile to more than 512MB. Use a 1Q, 2Q, 4Q or 8Q profile then see what happens. Once you have it working, you can then experiment with different profiles to get the best experience.

Typically, I would just completely ignore the 0B and 0Q profiles, as they do not allow the use of NVenc.

GRID drivers are ISV certified in the same way Quadro are, so this won’t be your issue.

Regards

No image appears.

Regards

And is it only when you use Citrix? What about RDP?

What else have you tried so far? …

I have just changed the Profile configuration and assigned the machines to the user for testing. I would have to come back on Monday with the results.

RDP would not work, since I would not be able to access the Machine once NVIDIA driver is installed. And I believe the grid card functionalities would not be available through RDP. Please do correct if I’m wrong

Not all features are available, but you can connect and test with RDP and the GPU does get used :-)

Once the GRID driver is installed, you can’t use the ESXi console, maybe that’s what you’re thinking of?

Yes, I should still be able to connect through RDP.

Though I am yet to get feedback from the users, but I am wondering if it would work due to licenses.

We actually licensed "Grid Virtual PC", which I believe covers only "B" and "A" profiles. Though 0Q might work, but would 1Q - 8Q work when we do not have the appropriate licenses.

Got feedback from users.

Unfortunately none of the profiles (1b, 0q, 1q, 2q, 4q, 8q) works. Same with RDP as well.

Hi topokin,

still not sure what the issue is but first of all I would recommend to check if your VM is working in general. Please use DXdiag and for example: http://realtech-vr.com/admin/glview to check the OGL capability within your session. Afterwards you should know if it is a general issue or application related.

Regards

Simon