Nvidia Jetpack 4.6 Tensorflow Container Dependency Clash

Description

Hi all,

I recently purchased a new Jetson AGX Carrier board from auvidea (x221). My requirement is to get FastMOT (GitHub - GeekAlexis/FastMOT: High-performance multiple object tracking based on YOLO, Deep SORT, and KLT πŸš€) running on this board.

The latest firmware available to me from Auvidea only supports Jetpack OS 4.6, which I have successfully installed.

The issue comes when installing requirements for FastMOT, I can successfully install all dependencies aside from:

  • Scipy >= 1.5
  • TensorFlow < 2.0 (for SSD support)

Scipy requires python version 3.8 or higher, so I have set up a virtual environment running python3.8 and installed successfully.

As far as I can find, Nvidia’s Tensorflow Containers for Jetpack 4.6 all require python3.6. I am yet to find a version that will install in my virtual environment. I have successfully installed an Nvidia Tensorflow Container outside of my virtual environment however this doesnt help me as it is running on python3.6.

Any ideas how I can resolve this?

Environment

GPU Type: Jetson AGX Xavier
CUDA Version: 10.2
CUDNN Version: 10.2
Operating System + Version: Jetpack 4.6
Python Version (if applicable): 3.6.9/3.8

Hi,

We are moving this post to the Jetson AGX Xavier forum to get better help.

Thank you.

Starting point for your question

Scipy requires python version 3.8 or higher

I am not understanding here. What is your problem?
The scipy installed in my python 3.6.9 virtualenv is 1.5.4. It’s not python 3.8.

If you need tensorflow with python 3.8, you will need to build tensorflow from source, I would suggest starting with the l4t-base container.

Hi,

This looks like a Jetson issue. Please refer to the below samples in case useful.

For any further assistance, we will move this post to to Jetson related forum.

Thanks!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.