NVIDIA Nsight v 5.1.0.16062 - missing call stack in Analysis

Hello.
I try to profile directx application with NVIDIA Nsight Analysis. I follow documentation and tutorial video with serious sam 3 profiling. I launched Analysis on local machine with VS2013 (with opened solution). The problem is that I can’t get an appropriate stack trace pointed to my code. Any call shows only the hexadecimal address, the module name but nothing else.
I tried to profile another application in VS2010 but got the same issue.
I found the same problem here https://devtalk.nvidia.com/default/topic/528962/missing-call-stacks-in-nsight-3-0-rc1-and-2-2-and-2-1-/
Should I setup any paths in Nsight or adjust something else? How to fix this problem?

Best regards.

Hi vdontsov,

Please confirm something:

  • you run your Nsight monitor under admin privilege
  • you select ‘System’ in Trace Settings, Nsight Analysis need this option to be selected for collect stack trace
  • you need to select ‘Call Stack Trace’ in ‘OpenGL’/‘Direct X’ from ‘None’ to ‘Always’

After that, you should have the ability to collect proper data about stack trace and see it in your timeline page.

Thanks
An

I confirm. The result is the same.
The next things I get:
Timeline stack trace:

Modules tab:

Should I adjust something in th Nsight options? (e.g. Symbol Management)

For some reason it swaps discs name in modules path.
https://pp.vk.me/c626718/v626718528/793f/DaTLHklfkLo.jpg

Windows is located on “C” and my app is located on “D”.

Seems like a bug.
I created symbolic links to solve this problem.

Hi vdontsov,

Umm, that’s weird, could you try these:

  • set Resolve Symbols back to default: ‘Using symbol server’
  • leave Symbol Cache Path and Symbol Server Paths to null

Do you run your sample remotely? It’s weird that some system dll are located in D:\ but not C:\

I tried on my local machine, that works fine.

Thanks
An

No, I run my sample on my local machine.
I’ve tried to apply your options, but it doesn’t help. System dll are located in C:\Windows but NSIGHT thinks that they are in D:\Windows.

Hi vdontsov,

There might be some settings make things mess up. Could you please try to delete these:

  • back it at first
  • remove C:\Users$(user_name)\AppData\Roaming\NVIDIA Corporation\Nsight

Take another try.

If it keeps happen, could you please share your sample to us, I want to do a local investigation.

Thanks
An

FYI. The bug still exists in 5.6.0.18146
My application dll’s are located in D:\ but Nsight modules paths points to C:\