Dear Linux Bug Support,

nvidia-bug-report_Server.log.gz (331.9 KB)
nvidia-bug-report_Client.log.gz (334.9 KB)

I’m currently working on a NVIDIA Quadro Framelock setup on Linux. I have two PC systems. Each system has 1 Nvidia Quadro RTX 5000 connected to 1 Nvidia Quadro Sync II by ‘sync’ connector. The two systems are in a local network (through Ethernet port of motherboard), and the two Quadro Sync II are linked by a CAT5 Eth cable. I want to synchronize the display with only internal signal, no External house sync signal is required.

(Frame lock not enabled on this picture)

The first thing to say is, while testing this setup on Windows by simply following the Quadro SYNC II documentation, there was no problem and I obtained good SYNC, with no desync, and without any extra configuration.

On Linux, after following the guide, at the time “Enable frame lock” is hit (or command /FrameLockEnable=1 sent), the process seems to start, then some seconds later (usually 5/10 secs) client displays black frame randomly, while LEDs status widgets (nvidia-settings “frame lock” tab) switch to red. It seems it’s a desync problem. The card physical LEDs indicate : synchronizing → synchronized → synchronizing → synchronized and so on, without any stabilization. I thought it was a timing / refresh problem so I setup a precise timing mode in xorg.conf to get identical timing modes. Xorg logs says Modeline specified is used (I decoded the EDID of the display to write the good mode), but no improvement in the setup. I also tried to put card to persistence mode, as I thought it could be a power / energy save problem. I also tried to put the CPU governor to performances… No results.

Environment is as follows :

  • Display stack : lightdm + Xorg

  • Ubuntu 20.04.5

  • Linux kernel 5.4.0-126-generic

  • Drivers tested: 470.129.06, 495.46, 510.54, 515.57

  • Sync II firmware is 2.02 for each Sync II card

Bug reports are generated with 470.129.06 driver while Frame lock is enabled (and resynchronizing every 5/10 secs with black frames). You 'll find attached a bug report per machine (Server / Client).

setup from nvidia-settings :

xorg.conf contents

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Seiko/Epson EPSON PJ"
    Modeline    "MyModeLine" 148.5 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync
    Option         "DPMS"

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "Quadro RTX 5000"

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "3"
    Option     "MetaModes" "MyModeLine +0+0"
    SubSection     "Display"
        Depth       24

I also tried to setup to “0” (Disable). I tried with and without the Modeline setup, no better results. Every observation we made indicate me it could be a problem of the firmware or the driver / status of the cards. Could you give me some assistance to operate this setup correctly ?

I also tested to use 2 Quadro RTX 5000 connected to a single Quadro Sync II inside the same PC, and it worked without any extra config on Linux.


Did you enable tcp connections to the Xserver on the client? i.e. starting it with -listen tcp option and using xhost to allow connections from the server.
To check, you could run on the server
DISPLAY= xterm
and check if the xterm is displayed on the client.

Of course “xhost +” command is done correctly.
You cannot add a remote device in the frame lock menu of nvidia-settings unless it’s done correctly.

Looking at the logs again, there’s a KVM reported, is that used to connect the monitors? If so, does it sync with the monitors directly connected to the gpus?

KVM is only used for Keyboard / Mouse, no Display connected to it.

Ok, shouldn’t be an issue then.
While it shouldn’t have an influence, please check if running

sudo cat /sys/module/nvidia_drm/parameters/modeset

returns ‘Y’ and in that case disable drm modesetting

I just retried the setup and had the same behavior of desync after 5/10 secs.

On both client and server, /sys/module/nvidia_drm/parameters/modeset contains ‘N’.

Is there a method to retrieve more log / debugging information of sync process to identify this problem ? As explained before we do not have this behavior on MS Windows.

Also tried :

rmmod nvidia_drm
modprobe nvidia_drm modeset=1

No change. Any idea ?

Actually no idea. Please check if you can get any answer from quadrosvs[at]nvidia.com and maybe also post in https://forums.developer.nvidia.com/c/gaming-and-visualization-technologies/visualization/mosaic/172
Maybe a mod there can gather some info about the issue.