NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. UBUNTU 20.04 RTX3050

Hello everyone,
I tried to install the Nvidia drivers from the software and update section and it was installed, then the system got updates. When I came today, ubuntu did not open and when I deleted the ubuntu drivers, it opened. I tried doing the latest install from CUDA Toolkit 11.7 Update 1 Downloads | NVIDIA Developer in many ways but the drivers didn’t work.
I ran nvida bug reporter nvidia-bug-report.log.gz (231.8 KB)

. But when I ran the command (“startx – -logverbose 6”) it gave me the following return .

/usr/lib/xorg/Xorg.wrap: Only console users are allowed to run the X server
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error
Couldn't get a file descriptor referring to the console

And nvidia-setting page it looks like this
Screenshot from 2022-08-11 11-35-59
Secure boot is disable.
Kernel verison is 5.16.0-051600-generic.


I reverted to the base kernel version but nothing changed.

According to the log, nvidia-515.65.01 for kernel 5.15.0-46-generic was compiled and installed fine today.
Please create a new nvidia-bug-report.log with the current kernel.

nvidia-bug-report.log.gz (188.4 KB)
Kernel version is 5.11.0-27-generic right now.

Don’t have any solution?

That’s a really old kernel that doesn’t have any headers installed. Please boot to the correct, current 5.15.0-46-generic kernel.

Now Running kernel: 5.15.0-46-generic. But problem isnt solved. My problem maybe not related to kernel version. when ı prime select nvida drivers,ubuntu not opening. Stays here

And new bug file is :
nvidia-bug-report.log.gz (186.6 KB)

Please delete /etc/X11/xorg.conf

Thank you generix. This solved my problem.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.